COBOL Analyzer Tutorial

Module O -- Workspace build and troubleshooting

Purpose

You will learn to build a workspace and setup the training materials for this course.
You’ll also learn about common issues and how to resolve them.

General

COBOL Analyzer works by first loading the source repository, parsing it using the Micro Focus COBOL compiler, analyzing
it using the COBOL Analyzer analysis engine and finally loading the analysis data into a database.

Once this has been completed, you'll get the full analysis information exposed in various different views using the
COBOL Analyzer desktop client

Exercise 0-1: Getting familiarized with the workspace build wizard

This tutorial will utilize the Micro Focals sample code provided. The objective of the tutorial is to provide familiarity with
the COBOL Analyzer and creating new workspaces.

1. Open COBOL Analyzer
2. Inthe Open Existing Workspace dialog, click on “Create New”
3. The tool will close, and a wizard will pop up, if this doesn’t happen, re-open the tool as administrator and

follow step 3
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4. In the first wizard page, you can name the workspace and choose its location:
(2] Workspace Build Wizard - Workspace configuration = =

@ Micro Focus® COBOL Analyzer® Workspace Build Wizard

This Wizard guides you through the process of building a new Workspace.

Please select the name and location to save the Workspace.

New Workspace Name:
MyNewWorkspace 1

New Workspace Location:
C:\Work\EA\CAWS2

Click 'Next' to proceed.

>

Click “Next”.

5. Inthe next page you can choose the COBOL dialect (Micro Focus, ACUCOBOL-GT(R) or RM/COBOL) and compiler
level (MFLEVEL) depending on the product that is used to compile the code.
You also need to add any compiler directives that are needed in order to compile the code. Linker related
directives are not needed. You can also use a directives file by using the USE compiler directive (for example:
use(console.dir))
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® Workspace Build Wizard - COBOL Dialect options

@ Micro Focus® COBOL Analyzer® Workspace Build Wizard

Please specify environment settings for your workspace.

COBOL Dialect:

Micro Focus ]

Select Micro Focus compiler compatibility level
(keep the default if you are not sure which product to select)

Defautt (MFLEVEL"15") v

Compiler Directives: (one per line)

Click 'Next' to proceed.

Help < Back Next > Cancel

Click “Next”

6. Inthe next page you need to specify the folders that contains your source code files, the recommended setup is
to have one root folder that contains all the folders and sub folders that contain your sources.
There are multiple ways to add source code in the next pane:
a. You cantype the path in the “folder:” text box
b. Use the browse button to navigate to where your source code is located or
c. Dragand drop a folder from Windows Explorer. (Support depends on your Windows OS version and
User Account Control settings)
d. Import a Visual COBOL project file
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@ Workspace Build Wizard - Add Files for analysis — hd

@ Micro Focus® COBOL Analyzer® Workspace Build Wizard

® Add sources manually
Please select the folders where your files for analysis are located.
Folder:

Z || 8] | e

Selected:

Mote: Sub-folders will be automatically included
If you have multiple versions of some files, you can set the priority by moving your filesffolders up or down.

O Import sources and properties from Visual COBOL project

Click 'Next' to proceed.

Add a folder and click “Next”.

7. The next page is an optional extra settings page.
In case you have dedicated folders that contain copybooks only (libraries folders), and specifically when those
copybooks do not have an identifying file extension such as “.cpy” etc., specifying those folders would help
COBOL Analyzer to identify the required copybooks and analyze your source code correctly and quickly.
You can expand the folders tree on the left and add the libraries folders to the Copybook directories list by
clicking the ‘Add’ button.
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(5] Workspace Build Wizard - Copybooks Options =

@ Micro Focus® COBOL Analyzer® Workspace Build Wizard

(Optional) Please specify the copybook directories if you have copybooks with _cbl extension.

Folders: Copybook directories:
- C\Work

Add >

Click 'Next' to proceed.

Help < Back Next = Cancel

For our example we have no settings to update, so click “Next”.

8. Next you get a list of all the files that COBOL Analyzer didn’t identify by their extension.

You need to review those files, select the extension and use the file type drop down and the * Associsle | 1 tton

to associate them correctly.

Another option is to click the *E Auto-Associate All 1y 440n and let COBOL Analyzer parsers decide by the files
content.

Most of the cases when we encountered unassociated files they are either files that are not part of the
sources (project files, binaries, document etc.) or copybooks.
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@ Micro Focus® COBOL Analyzer® Workspace Build Wizard

(Optional) There were some files that could not be associated with any source type using their
extension. Please click on an extension, pick a file type, and click the "Associate” button below.

@ Workspace Build Wizard - Copybooks Options = d

|

Extension File Count Sample File ~
APP 1 Citemp\CADEMOWMlicroFocals\MicroFocalsDemo APP

.cache 1 Cltemp\CADEMOMicroFocals\objx86\Debugimfocal.cblprojResolve...
.cblproj 1 Citemp\CADEMO\MicroFocals\mfocal.cblproj

.cfg 1 Citemp\CADEMO\MicroFocals\gb\extfh.cfg

.cobolBu... 1 Citemp\CADEMO\MicroFocals\.cobolBuild

.cobolPraoj 1 Citemp\CADEMOWMicroFocals\.cobolProj

config 1 Citemp\CADEMOWMicroFocals\Application.config

.css 1 Cltemp\CADEMOWMicroFocals\md.css

.dat 10 C\temp\CADEMO\ metadata\ plugins\org.eclipse jdi.core\variablesAn...
.DBK 3 Ctemp\CADEMO\MicroFocals\gb\consultants. DBK

dep 1 Citemp\CADEMO\MicroFocals\mfocal dep

.exe 3 Cihtemp\CADEMOMicroFocals\binix86\Debugimfocal.exe

.gef 1 Citemp\CADEMOWlicroFocals\New_Configuration.bin\New_Configura...

H 1 Citemp\CADEMOWMicroFocals\MFRES H e

Unassociated Files: 240

File Type:
v | ¢ Associate Y= Auto-Assaciate All

Click 'Next' to proceed.

<Back | Next> Cancel

9. Inthe last page you’ll have 2 options, creating the workspace but not analyzing the files yet or creating the

workspace and analyzing all the files.

The analysis could be time consuming when loading a large amount of code (millions of lines of code), so in that
case and if this is a first trial of analyzing the code, the recommended course of action is to add files without
analysis and analyze several files from within the tool before kicking off the analysis of all the source code.

If however this is a small source code repository or you are confident that the analysis will pass without issues,
choose “Analyze all files”. Our sample is relatively small in size so we will select “Analyzer all files”.
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@ Workspace Build Wizard - Build workspace = =

@ Micro Focus® COBOL aﬂ\naJyZQr0 Workspace Build Wizard

Please select one of the following options:

® Add files Allfiles selected earlier will be added to the Workspace
without analyzing but no analysis will be done.

) Analyze all files Allfiles selected earlier will be added and analyzed.
(94 File(s))

Click 'Build' to proceed.

< Back Build Cancel

Click “Build”
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10. The Workspace build process will start. When it is finished, the newly built workspace will open automatically
and the workspace build summary page will appear:
® Workspace Build Wizard - End = =

@ Micro Focus® COBOL Ana]yzer“ Workspace Build Wizard

The Waorkspace creation is now complete. Please check the summary below.

Summary
Additional Tasks

No additional tasks.

General Information
Total files added: 90

Auto-associated files: 0

Unassociated files: 3
Workspace Name: MyNewWorkspace1
Workspace Folder: C\Work\EA\CAWS2\MyNewWaorkspace1

Click 'Finish' to close the wizard.

Help < Back Finish Cance

Click “Finish” and the wizard will close and you will see the COBOL Analyzer Dashboard.
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e Pt | s | Frmacireation ezl
[
B v Gbject Trpes Cyclamatic Complexity
]
| \ > 4 ?
L - . 4
1
¢
e Teapme  [veres  [emree Tomme Theme T [

e EE

Page 8 of

Micro Focus, LTD. 2019 53



COBOL Analyzer Tutorial

Unzip CADEMO.zip

Open COBOL Analyzer

In the Open Existing Workspace dialog, click on Create New

The tool will close, and a wizard will pop up, if this doesn’t happen, re-open the tool as administrator and
follow step 3. If this doesn’t solve the problem, continue to the next exercise

Follow the wizard instructions and click next

On the second wizard page, add use(console.dir) to the compiler directives box or copy and paste the content of
console.dir that resides next to the source files.

7. Onthe next page add the MicroFocals root folder (Browse, drag and drop or copy paste should all work)

8. Click next until you get to the 5" wizard page.

9. Choose Analyze all and click build

10. You should have 1 file with errors (autosetup.cbl), this is expected and part of the training.

11. You can try solving the problem yourself using the getting started pane or follow the tutorial. In any case, one
file with errors doesn’t prohibit you from analyzing the rest of your project.

= Rl

o w

1. Open the COBOL Analyzer Administration
2. Click Administer-> New workspace...
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3. Choose the MS SQL Server Express option and click OK

Create new workspace H

@ Micro Focus® COBOL Analyzer®

Mew |
R Rl
SaL SQL
Mew Workspace Mew Workspace
(M5 SQL via OLE DE) (Small Local Worksp...

k.

Cancel

Wizard | Help

il

4. Assign a name and location to the workspace and click save

® New workspace
Save i_r|:| L CAWSET j . 0 e
Mame : Date moedified Ty

Mo iterns match your search,

< >

Fiepame: | | save |
Save as type: II'u'Iicm Focus COBOL Analyzer workspaces {‘;I ﬂl
s

5. Open COBOL Analyzer and open the newly created workspace
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6. Click Workspace—>Add files to workspace and choose Add Folders

7. Browse to the MicroFocals folder that you extracted from CADEMO.zip
8. Click Continue on the Registration dialog

9. Inthe Add Files to Workspace dialog, DO NOT VERIFY, click close

Add Files to Workspace

@ You've successfully registered 89 file{s), There were 95 file(s)

ignored.

IICKE NEre 1or Oels

# Options|~ Verify | Close

| Mever ask again

10. Go to Options=>Workspace options—> Verification tab
(1 Options - Warkspace

9 General ] E Registration @ Verification l B3 system Programs ] [} Homonyms ] Ez Glossary | Search Assistant
Legacy Dialects ngttings ] Defects Messages ]

Source Type

COBOL Dialect |Micro Focus j

Micro Focus compiler compatibility level: |De1’au|t (MFLEVEL"157) j
Compiler Directives
use(consale.dir)

11. Right-click on the Compiler Directives box and choose Add

12. Add use(console.dir) or check one of the entries that already contain console.dir

13. Click OK

14. Right-click on the project in the repository pane and choose Verify

15. You should have 1 file with errors (autosetup.cbl), this is expected and part of the training.

16. You can try solving the problem yourself using the getting started pane or follow the tutorial. In any case, one
file with errors doesn’t prohibit you from analyzing the rest of your project.

Exercise 0-4: Solving analysis errors and issues

In COBOL Analyzer and this tutorial errors in the analysis are sometimes referred to as verification errors.
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1. Follow the getting started first category:

Make sure your workspace is verified and up-to-date:

& Generate an Inventory Report.

& Fix the errors found while verifying yvour sources, by double-clicking
the files in the Repository pane and examining the errors in the
errors pane.

* Alernatively, use the Verification Report to examine the errors.

2. Click on the inventory report to get an overview of your workspace:

@ Inventory Report - MFocal (MFocal) - O X
File View Help
Type Source Lines Quantity Unverified Verified Erroneous Relaxed Missing
Workspace [ Jmrocal | 10122] _ sa] | 3| | 1] 1
COBCL File 5,004 36 35 1
[ Copybook Fie 5,118 56 56 1
EI Directives File for Checker 2
All Projects & Total 7446 B9 51 35 1 1
COBOL File 5,004 36 35 1
[ Copybook Fie 2,442 51 51 1
E‘ Directives File for Checker 2
Project & MFocal 7446 B9 51 35 1 1
% COBOL File 5,004 36 35 1
[ Copybook Fie 2,492 51 51 1
E‘ Directives File for Checker 2

You can see that you have one file with minor errors (relaxed) and one missing file.
3. Double click on the autosetup.cbl file (notice the yellow icon that indicates a minor error)

Sl 4Focal

=I5 COBOL File
+ ABC4400.chl @
+ autosetup.chl @
+ autosetup_test.chl @

4. Look at the errors pane just below the source editor, there is a missing copybook “missingcopyexample”:
| I [ Fall "PRL CHFCK FTIF F¥TET™ ncine

® Error 803 - Copvbook missingcopyexample.cpy not found

5. When you have a larger source repository with multiple errors the recommended way to resolve them is by
going over them in the verification report.
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6. Click the Verification report hyperlink in the getting started pane or under Reports menu item in the main menu:

[5] Verification Report - MFocal {MFocal) - O ®
File Edit View Help

- O% Projects Mrocl -

Errors Source - C:\MFOCALS\MICROFOCALS\AUTOSETUP.CBL

i\ Warnings M =[1s B

copy "cblproto”.

IS

Severtty Number Count Files Affected = Sample Message

Copybook missingcopyexample.cpy not found

program-id. autosetup.

environment division.
configuration section.
repository.

data division.
working-storage section.

copy "common 7E.cpy".

* Copy the missing copybook from the root folder to fix

01 File-Details usage cblt-fileexist-buf.
< > 01 status-cods usage cblt-rtncode.
[Ees Aftected by Evon Wmdier B0, (1) 01 poss-dir-count binary-long value 0.
Name Parse Status Emors Total  ~ Wamings Total Path 01 poss-dirs pic x(&4) occurs 5.
[ autosetup.chl Relaxed 1 0 CAMFOCALS\MICROFO.
b e ax 01 tmp-num-d pic 999 display.
01 tmp-count binary-long.
01 tmp-lang pic xx. *> size of 2 on purpose
01 file-status pic xx comp-x.
01 redefines file-status.
03 fs-byte-1 pic x.
< >

03 fs-byte-2 chlo-xl-compx.

Details for autosetup.cbl (1 error displayed)
bl = 01 mfocaldir-env pic x(255).

O Show All Errars 01 mfocalhdir-env pic ®x(255).

Number =« Message Object Source Line Column procedure division.

@03 Copybook missir cpy not found autosetup.... COBOL: CAMFOCALSWM... 15 30 display "MFOCALDIR" upon environment-name
accept mfocaldir-snv from environmenc-value
if mfocaldir-env not equal spaces
call "CBL_CHECK_FILE_EXIST" using
by reference mfocaldir-env

by reference File-Details =
< > [ T [ »

7. You can review the different errors, sort them by severity and see the number of files each error affects.

Fix the error by severity and re-verify to make sure they are fixed.
8. Click on File>Reports=> Missing files Entire Worlspace:

Verification Report - MFocal (MFocal)

Eile | Edit View Help

Refresh Errors F3 ects: MFocal -

I| Report » | Errors
Close Eiles Affected

Severty Mu Details
EM Details For Checked Files |

Missing Files for Project

Missing Files Entire Workspace

9. The report shows the missingcopyexample.cpy is missing and that it’s a copybook.
10. Close the verification report.
11. Click on Workspace—>Add files to workspace.
12. Choose add files.
13. Navigate to missingcopyexample.cpy
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a. You canfind it in the same level as the MicroFocals folder where you unzipped the training materials.
14. Right-click on autosetup.cbl and choose Verify.
15. Open the inventory report again and verify that everything verified correctly.

Common problems when loading new COBOL sources into COBOL Analyzer

e Missing files, especially copybooks:
o Review the error
o Search for the files
o Add to workspace and re-verify
e Missing files due to mismatch in extensions or relative location
o Make sure files are associated correctly in the wizard
o If the files are already in the workspace but associated to the wrong type, delete them from the
workspace and re-add with the right association.
o If you have copybooks that was wrongly classified as COBOL files, you can right-click on them in the

repository browser and select Change Type—> Change COBOL to Copybook File

Types Folders l
Make sure your workspace is verified anc

‘Sear:h workspace A\
@ Generate an nventory Report.
# Fix the errors found while verifying yo
o " A
E‘ Viorkspace in the Repository pane and examining th
& Alternatively, use the Verification Repor

=l TrainingMicroFocals
=I--{£§ MICROFOCALS

- [ TESTS Run various reports over your workspace
ABC4400.chl -]
o Verfy

E & |nventory Report - Key statistics of your
el Interactive Analysis @ CRUD Report - The data operations eac
CDF the data objects on which the programs

+
[
[
+
+ cor Open e Reference Report - Information about
+ cor . elements, and an overview of all of the
+ cor Query Repository 4 ® Quality assessment - A collection of ¢
0 % ad the code.
+ cu: Code Search Reports 3 # See more under the Reports menu.

B cus
+- (g cug Select »

Analyze relationships between your progr

[+ % dai B

E pand Subtree
+ [y e
i exd Show in Folders/Types view ® |nteractive call map - Visualizes the di

=1
[+ %ger Change Type 3 Change COBOL to Copybook File |
+ =g Assign Tags dependencies in the system.
4+ gei ® Data flow map - Visualizes data flow ac

e Special/custom preprocessors are used to compile the code so it’s not parsed correctly by COBOL Analyzer.

o If handling the code using the checker preprocessor directives (compiler directives box) doesn’t help,
preprocess the code before loading to COBOL Analyzer.
You can create a batch file that preprocesses the code and run it on every update of the workspace (see
source synchronization in Module 5 — Working with projects)

e Missing of compiler directives — As mentioned before, COBOL Analyzer uses the Micro Focus COBOL compiler to
parse the COBOL code. If there are specific directives that are needed to be set in order to have the code passing
compilation, make sure they are set in the appropriate place in the wizard or the workspace options.

e Wrong compiler compatibility level — If the code is originally compiler with one of the older products (Net
Express or Server Express for example), the right compiler compatibility should be set in the wizard or
workspace settings.
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Module 1: INTRODUCTION

This module of COBOL Analyzer training shows you how to use COBOL Analyzer to provide comprehensive analysis on
your legacy system, ranging from data flow of a data item to visually exploring the relationships between legacy objects.
COBOL Analyzer aids in your understanding, increasing not only knowledge of your system, but also assisting in any
redevelopment or enhancement efforts.

The aims of this module are to enable an COBOL ANALYZER (CA) user to:

Understand the relationships between repositories, workspaces, and projects

Manage projects

Diagrammatically and / or in report format, show relationships between legacy objects to facilitate application
understanding.

Trace the flow of data to and from a data element across a legacy system.

Establish the potential impact on a system resulting from a change in a data item’s definition or usage.

This training module is aimed at users of the COBOL Analyzer Developer Edition, containing all CA features. A separate
training module with a subset of these features is aimed at users of the COBOL Analyzer Standard Edition.

Workspace — folder containing sources on the app server. Objects are stored at the workspace level, and there is
only ever one version of the workspace sources.

Repository — schema on the database server containing information and relationships created as a result of
parsing the sources in the workspace.

Project — a default project with the same name as the initial workspace is created automatically. Additional
projects are created by the user. Projects contain “pointers” to the source; so, an object can belong to many
projects. Dividing the entire workspace to project is very useful especially when using Visual COBOL or planning
to upgrade to Visual COBOL. This will be covered in module 5 (working with projects)

Folders - contain objects of a specific entity type (Cobolsource files, copybooks etc.) based on the source file
extension. A Project can contain one or more folders. Some folders are automatically created as a result of
parsing (Program, Screen, Transaction, etc.)

In another view, folders can relate to actual folders on disk.

There are multiple ways to access tools and functions within COBOL Analyzer. Many features can be accessed by one or
more of the following methods:

Menu drop-down
Icon
Right click
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Options in CA are “context sensitive”, meaning that the options that display will apply to the object or entity you
currently have highlighted or selected with the cursor. For example, you can perform the “Query Repository” function
at the Project, folder or object level. You can even perform this function for a “list” in the View pane, if you have the
entire list high-lighted. Options that are valid for the entity type selected, but NOT valid for the current object will be
light grey (not selectable). The get-storeconf paragraph has been selected below in Interactive Analysis. There are
PERFORM statements in the program for this paragraph, but no PERFORM THRU’s or GO TO statements for this
paragraph. Therefore, those options are not selectable.

Source

File: ‘STORECONFicﬂMMON.CF‘Y

- =P B

get-storeco=*<
move O Parent
move O Back
open in
if wsa-f
ope Find...

Forward

wrd PERFORM Statements...
clo GO TO Statements...

stee PERFORM THRU'..
rea

clg Next Paragraph...
end-if Previous Paragraph...
End of Paragraph
increment-s ALTER Statements
perform | o o lapping PERFORM Statements...
add 1 t
open o Properties
write C
close = Refresh
Set Business Attributes...
save—stored Set Change Magnitude = §
open ou Set Change Magnitude = M
write Q
close d Set Change Magnitude = L
Set Change Magnitude = XL
Source 3
Context 3

Cede Search 3

Each window within COBOL Analyzer Interactive Analysis consists of multiple panes which can be opened using the View
option from the menu bar. Panes are activated by toggling on/off from the Menu drop-down. Some views can also be
activated via function keys; for example, panes on the Repository Screen. You can close any pane in CA by clicking the
‘X’ in the upper right corner of the pane.

The Repository Browser pane can contain up to 3 tabs; Folders, Types and Legacy Search. In addition, “Repository
Search Assistant” (Search workspace) is available as an entry box on both the Folders tab and the Types tab. The third
tab, Legacy Search, becomes available if you have selected “Search” from the Menu option within the current session.
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Folders

Displays the contents of the repository in the same folder structure as that in which the source was loaded. This can

have the same structure as the host environment and allows for elements with the same name (homonyms) to be
loaded and displayed.

Types
Displays the contents of the repository by project and entity type.

®

@' Workspace Edit Search VWiew Prc
@l AR M YE
Project: | T |Mai

Folders Types l

Search workspace N

- % MainLogic
+-- (73] ‘COBOL File
+-- [0 Copybook File
+--[E3 Program
+- [ Sereen
+ EE.&? MicroFocals4

Legacy/Text Search

Displays the list of objects that met the Search Criteria of the last executed search. Each of the “Folder” and “Types” tabs
consist of the following elements:

e Browser -- Shows the objects in the repository of the current workspace in a tree structure. Depending on the

tab you have selected in the Repository Browser pane, the contents are displayed either by type or by folder.

e Search (Search Assistant) -- Lets you execute various searches in the repository of the current workspace.

e Project Filter -- Allows you to filter the projects that are displayed in the Browser pane. Project filter makes use
of “wildcards” and regular expressions (except #). Wildcard * is assumed at the end of the filtered name.
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Exercise 1-1: View Entire Workspace

Objective: Open and View the Workspace

1. From the View menu, select Entire Workspace. We will use the Workspace View later on in the training. For
now, be aware that the workspace contains additional information that may not be available at the project level.

®

@ Workspace Search

‘l."iew| Project Prepare  Analyze Reports Optiol

(e N |

Repository

Folders Types |

ISear:h workspace

E%

Bl-- [ COBOL File

- [7] Copybook File
-[27 Directives File fi

-3 Program

Folders
Types
Refresh Browser F5
Chart Viewer
Refresh Chart Viewer ?
Custom Report Results F3 | Q,
Object Information F2
Activity Log Ctrl+L
Getting started
Properties F4

- I:I Screen

2. Expand the folders under

the workspace by clicking the + sign. Notice that the workspace is represented by a

filing cabinet icon. Any functions that are available from the Analyze drop-down of the menu are ONLY valid for

‘Projects’. So, if you have
functions. For that reason

the workspace folder active (highlighted), you will not be able to choose any Analyzer
, we will close the Workspace view when not in use.

Page 18 of

Micro Focus, LTD. 2019

53



COBOL Analyzer Tutorial

R.epository x|
Folders Types | Y
ISear:h workspace Ql
L:_l..

~[Z3 COBOL File

~[7 Copybook File

~ [ Data Store

~[7 Dedsion

- [Z7 Directives File for Chedker
~[Z3 File

- @@ Program

- @@ Program Entry Point

~[Z7 Screen

- @@ System Program

- [Z3 Table

T TrainingMicroFocals

- [£3 COBOL File

- [7] Copybook File

- [27] Directives File for Chedker
- 23 Program

- [7] Screen

m

P

3. You can toggle View Entire Workspace ON and OFF by pressing CTRL+W.
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Module 2: COBOL Analyzer DOCUMENTATION

Introduction

A complete set of COBOL Analyzer manuals are installed in C:\Program Files (x86)\Micro Focus\COBOL Analyzer\Docs
when you install the workbench using the default location.

Exercise 2-1: Reviewing the Documentation
Objective: To successfully open and review the COBOL Analyzer online documentation.

1. Navigate COBOL Analyzer installation folder (usually C:\Program Files (x86)\Micro Focus\COBOL Analyzer)
Navigate to the docs folder.

3. Review the available pdf files and select the appropriate file for viewing. COBOL Analyzer.pdf has a Getting
Started section which is a good introduction to COBOL Analyzer. It also contains a description of the other

manuals.

Marne Date modified Type Size

=L COBOL Analyzer.pdf 11/10/2016 2:34 AM  Adobe Acrobat D... 4,255 KB
| Eclipse_Plugins_Readme.txt 87772015 2:03 AM Text Document 4KE
::ﬂ HeoganExamplezip 3/11/2018 1:19 PM WinZip File 11 KE
=L IMS Administrator Guide.pdf 10/28/2014 1:26 PM Adobe Acrobat D... 419 KB
"L Install and Deploy EAWeb.pdf 3/11/2016 1:19 PM Adobe Acrobat D... 245 KB
"L Installing EA Plugins for Eclipse.pdf 10/28/2014 1:26 PM Adobe Acrobat D... 442 KB
®L Search Assistant Eclipse Plugin.pdf 10/28/2014 1:26 PM Adobe Acrobat D... 271 KB

NOTE: In addition to the training manuals and User Guides provided in the Documentation folder, the application

comes with a complete set of Online HELP.

Exercise 2-2: Accessing Online Help File
Objective: To successfully open and review the COBOL Analyzer online help files.

1. Press the Help menu item and select Help Topics.
2. Pressthe F1 key to access context sensitive help.
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= COBOL Analyzer 2.0 -0
8 cl A} [
Hide: Locate  Back Home Prrt  Options
. ~
Cererts | e | search | ravortes | Introducing COBOL Analyzer

% g;‘fii‘,:h;{;f::e Micro Focus COBOL Analyzer (CA) offers centralized storage

oo e and analysis of enterprise application portfolios:
! COBOL Analyzer Products

How COBOL Anahyzer Models Appiications « Language-specific parsers generate a common
Workspaces and Projects repository of application objects, in the industrial-
Single-User versus Mutiuser Environments strength DBMS of your choice

Mutiuser Envionment Basics

COBOL Analyzer Basice « Sophisticated analysis tools give you converient
@ Propaing Projects interactive access to the repository. in a multiuser
@ Arclyzing Projects environment that facilitates exchange of information
@ Analyzing Frograms and insight across the enterprise.
@ Creating Components
@ Using the Batch Refresh Process The result is a single easy-to-use interface in which you
@ Using Architecture Modeler analyze assets written in modern languages like Java and C#
@ Support Notes alongside assets written in legacy languages like COBOL and
@ Complexy Metrcs PUILAnd in which you perform the analysis with industry-
@ Relationship Projections Ieading tools that offer deep, dstailed, and comprehensive

insight into complex moder distributed applications

COBOL Analyzer Products
Introduces COBOL Analyzer products

How COBOL Analyzer Models Applications
Introduces the COBOL Analyzer object and construct
models.

Workspaces and Projects
Describes COBOL Analyzer workspaces and projects

Single-User versus Multiuser Environments
Compares COBOL Analyzer single-user and multiuser
environments

Multiuser Environment Basics
Introduces the COBOL Analyzer multiuser environment

The information in the right pane is hyperlinked to enable you to navigate to the documentation
easily.

The four tabs in the left pane, Context, Index, Search, and Favorites offer different interfaces for finding the
information that you are looking for.

Context: The Table of Contents is organized like the external documentation. Expand the different
sections of the document and click on the topic that you want displayed in the right pane.

2
o OE e AT

Hide Locate  Back Home Prirt  Optior

Contents l Index | Search | Favorites |

@ Instaliation Guide

= m Getting Started
¢
@ COBOL Analyzer Basics

@ Preparing Projects

@ Analyzing Projects

@ Analyzing Programs

@ Creating Components

@ Using the Batch Refresh Process

@ Using Architecture Modeler

@ Support Motes

@ Complexity Metrics

@ Relationship Projections

3. Click on the Index tab.
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o= B & AT

Hide Locate Back Home Print  Options

Conterts  Index lgearc:h] Fa\tori_tes]
Type in the keyword to find:

entities

object model

relationships

MET suppart

activity log

Activity Log

AddMew bj

Advanced Search facility

AffectedCodeReport b

AnahyzeProgram bj

Animatar

Application Anabyzer

Application Architect

applicationdevel metamodel

ApplyPCF bj

Architecture Modeler
adding a source file
defining ertity tvpes

a. Type in a word in the top of the left pane to show the index for that area.

b. Click on a word or phrase in the left pane and the topic will be displayed in the right pane.

c. When there are multiple choices for the phrase, a list box pops up for you to choose which
topic you are interested in.

4. Click on the Search tab. This tab allows you to find documentation easily.

d. Type in a word or phrase and the matching words will display in the middle pane on the left
of the window.

e. Click on List Topics button and Topics containing that word display in the bottom left pane.

f. Double-Click on a topic and it is shown in the right pane.

= COBOL Analyzer 2.0 = =
& Al -
Hde Locate Back Home  Prnt  QOptions

Search it " . . ~
Cortert | bder 521 | Favotes | Understanding Data ltem Classification
Suppose your erganization s considering adding support for a
= =] 1| | | new currency and that you are going to have to expand the
existing exchange rate data [ from 9(5)V3(3) to 3(5)V9(6)

to the currency. You will need to know the data
Select topic Found: 151 [TEFE that are affected in the database, intermediate

that might contain or use the exchange rate [ in

Type in the word(s) te search for

List Topics | Dspley_|

R

7 calculations, and so forth.
Lists Pane BO 2
Sample Usage of Change .. COBOL Analyzer . 3
Corfiguring a DB2 ODBC D... COBOL Analyzer 4 Seed m
Synonyms and Ports Pane  COBOL Analyzer . 5
Setting Diagrams User Pref... COBOL Analyzer.. 6 Use Change Analyzer to search for the exchange rate .
Identfying |/0 Data Eleme. . COBOL Analyzer .. 7 The object of the search is called a seed [EE:
Manualy Extracting Busine... COBOL Analyzer .. 8
Detecting Synonyms and P...  COBOL Analyzer 9
Searching for Seed Fieldsi.. COBOL Analyzer . 10 o Ilithe application uses [T names fike EX-RATE,
Usingthe vars Tag COBOL Aralzer . 11 EXCH-RATE, EXCHANGE-RATE, and RATE-OF-
Database File COBOL Analyzer 12 EXCHG, you would search for data names that contain
Map COBOL Analyzer ... 13 *EXGH® or "RATE"
Specifying Control Conditions  COBOL Analyzer .. 14
Getting Startedin the Comp... COBOL Analyzer . 15 « I you know that some [FE already contain the
Selecting Fields COBOL Analyzer 16

required number of decimal positions, and are

Moving or Copying Felds B... COBOL Analyzer .. 17 interasted only in those that don't, you might further

e ovaries ConoL e 18 limit the search by fitering on the PICTURE clause
Creating 2 Workepace i 5., COBOL Andhasr .. 20 format of the variable, selecting only data items that
Defining a Search Fiter COBOL Analyzer . 21 have a format of 9(5)V9(3).
VE Class COBOL Analyzer 2
How Parameterized Sices .. COBOL Analyzer . 23 « You might limit the search even further by choosing
Connecting to 3 Workspac... COBOL Analyzer 24 [TFE that have a given initial value
Source Pane COBOL Analyzer... 25
Java Support COBOL Aralyzer .. 26  Ifyou know there are data [E[E that will meet the
SQL Sarver Database Setup  COBOL Anahyzer .. 27 search criteria for name, but are not what you are
dertfying Classes of Data . CopoL Araeer - 28 laoking for, you might set up a list of names to
pecifying Formatting Optio.. COBOL Analyzer . 29 m .
Jova Package COBOL Aratyzer . 30 exclude, such as INTEREST-RATE and "PRORATE".
Editing the Comment for a F... COBOL Analyzer 31 v
< > Synonyms
[~ Search previous results
[V Match similar words Once you have found the exchange rate 2. you can use
[ Search tles oy Chang'Analyzer to detect its synonyms. A synonymis a v
it B s sl e cnltas 41t sl o el P o
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5. Click on the Favorites tab. This tab allows you store commonly used Help windows for easier
access in the future.

E% COBO
S -
Hide Locate Back Home Print  Options

Qorrtents] Index ] Search Favortes ]

Topics:

Analyzing Impact Traces

Understanding Data tem Classification
ing Source

chronization

Display
Add
Remove

Rename

e Add stores the current page as a favorite

o Display shows the selected page in the main Help window

¢ Remove removes the currently selected page from the Favorite list

e Rename allows you to change the name (defaulted from the help text) to something more meaningful

toyou

6. Use the following buttons to navigate through the Help documentation:

% COBOL Analyzer 2.0
= A o
Hide Locate  Back Home Print  Qptions

o Hide: removes the list on the left side of the screen so that only the help topic is displayed. Show
redisplays the list.

e Locate: Identifies and highlights the document where the help is defined

e Back: returns to the previous displayed page

e Forward: advances to the next page

e Home: returns to the help home page

e Print: prints the page

Under the Options drop-down, are all of the above choices plus these options:
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COBOL Analyzer 2.0
Er-
Qptions
Hide Tabs
Locate
Back
Forward
Home
Stop
Refresh
Internet Opticns...

Print...
Search Highlight Off

e Stop

o Refresh: refreshes the screen display

e Internet Options: takes you to the Internet Options menu for your browser

e Search Highlight Off: toggles OFF or ON the highlighting of words that you are searching for in the Help
text

7. When you are finished, press the X (Close) button to close Help.
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Module 3: Configuration Options

Introduction

This section describes how to set various options within COBOL Analyzer. Options within COBOL Analyzer can be set in
two ways — either from the Tools menu or from the # button on the toolbar.

Obijectives

e You will explore the Options —User Preferences dialog box
e You will set values as necessary for your project needs

User Preference Options

There are three different types of options in COBOL Analyzer: User Preferences, Workspace Options, and Project
Options. User Preferences apply only to the current user. Workspace Options apply only to the currently open
workspace. Project Options apply only to the project currently selected in a workspace. Project options and Workspace
options will be covered in detail in the COBOL Analyzer Administrator training manual but those important to the regular
user are described during the relevant exercises in this course.

Note: In an Enterprise wide installation, unless you make these changes the default in Options Manager, changes you make
to the Project or Workspace Options will apply only for your user id. The Master user is the ONLY one who should use Options
Manager.

Environment

Exercise 3-1: Setting User Preferences
Objective: You will set user preferences in the User Preferences dialog box

4. From the Options menu, select User Preferences. Alternatively, you can press the Tools button  on the
toolbar.
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U Options - User preferences

rﬁ Diagrams ] Complexity Metrics ] '-3? Decision Resolution Tool ]
Search Assistant ]
# Environment l@ A_rdwivers] _! Ec_Iitor] ? Interactive Analysis]

After new files are registered
[~ Verify registered files

[v Ask user about verification

Custom Report Options
[v Ask user about running Custom Report for project

Chartviewer

v Show Chartviewer on startup

Show relationships in the object properties view window
™ Restricted to the current project

(* \Workspace wide

-

oK | Cancel |

Here you can see and change your current User Preferences settings. Review the other tabs and
the options described on them. Use F1 for help on what each option does.

We recommend setting the options as you see here. This should ensure that what follows is not
affected by any option changes.

“Show Chart Viewer on startup” is typically an option that can be turned off, especially if you do not
have the correct software to display the diagrams.

Depending on the Language add-ons that may be installed, this pane may vary. For example, if
Java parser is installed there is an additional option to provide the path to the required JRE folder.

5. Click on the appropriate tab across the top of the dialog box and set the values as necessary. You can press the
F1 key for information regarding each option.
6. When you are finished setting User Preferences, press OK.

Search Assistant

Exercise 3-1: Setting the Search Assistant options
1. Click the Search Assistant tab.
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2. Setthe Search Assistant options as seen on the left. This will ensure that future exercises will have consistent
results with the training material.

) Options - User preferences [ = ||
III{ Diagrams I Complexity Metrics I '—37 Dedsion Resolution Toal |

& Environment' EE Archivers I l Editor | ¥ Interactive Analysis |
Search Assistant |

Select the type of ohjects that will be shown in the search results:
[~ Select All

All Legacy

@5ysbem Program

1% erogram Entry Point

&% Data Store

Tabla

v Incude HC Objects
—Source Type

[Z7COBOL File Hypercode Entities
I~ selectAll

DEdaraﬁon

Paragraph

Variable

<]

OK | Cancel Apply

3. Click Apply and/or OK.
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Module 4: Repository Features

Introduction

On the Repository Browser pane, COBOL Analyzer allows you to filter and select objects by name with or without using
wildcards. Filtering is done by object type and can be used to select specific objects by full or wild carded name.

Exercise 4-1: Advanced Type Ahead

7. Switch to the Types tab in the Repository pane.

8. Inthe Repository pane, click the + icon next to the Cobol File folder to expand it.

9. Click anywhere within the list and start typing dat. Depending on how fast you type, your cursor will be
positioned at the first object within the list that matched what you typed.

Folders Types ]

|8&a|'ch workspace A

ST o gicorocs:] 2
=I5 COBOL File
+ [ ABC4400.chl @
auhoseb.lp.cbl L

autosetup_test.chl (2)
calcdistance. bl (2)
calcdtest.cbl @
cdookup.chl @
centertext.chl @
ConfigTests.chl @
constmenu.chl @
consultantsadd. cbl @
consultpopup.chl @
consultread.cbl @
consultsum.chl @
createstores.chl @
custid.chl @
custmaint.chl @
custmenu.chl @
CUSTNXKIN.chl @
CustomerTests.chl @
custpopup.chl @
custread.chl (2)
dateinfo.chl @
dateinfo_test.chl @
delappoint.cbl @

[ errpopup.cbl @

+-#--F-F-E-E-E- - E-E-E - w-w-w- - - E- f- -

Exercise 4-2: Text Search of the Repository

COBOL Analyzer allows you to search the objects in the workspace repository using various search criteria as filters. You
can filter on object name, verification status, and matching text. You can also replace text, if you have CA Administrator
access. A more advanced Search facility is available in Interactive Analysis that we will look at later.

1. Select the project.
2. From the Search menu, select Find or press CTRL+F. You will see the Find dialog box.
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Find >
Find What: | |[=] [Findai_]
Search Mode e
[] Match whole word ® Plain Text
[] Match case () Regular Expressions
. Advanced

[] Skip Comments O Wildeards fly

Project: MFocal

3. Click the Advanced Find button to see additional options
4. Enter consult as the search string. You can enter plain character strings, regular expressions or wildcarded
search strings.

For regular expressions or wildcards, the right arrow button next to the drop-down will display a list of elements
you can insert in the pattern.

You can use POSIX regular expressions and wildcard patterns allowed in LIKE statements by .NET Applications.

5. Check the Skip Comments and the Verified Successfully check boxes. This will return results from actual
uncommented code in files that were analyzed without any errors or warnings only:

Find x
Find \what |consuit |[] [Fndai]
Search Mode Cancel
[] Match whele word @ Plain Text
[ Match case () Regular Expressions
. Advanced

[] Skip Comments O Viildcards i

Project: MFocal

Where Parse Status

[ Unverified [] Verified with Relaxed Parser
[] Verified with Errors [] Verified Successfully
Loak In
Scope: | Selection v

Search in: |Pr0ject: MFocal |

Object Name Like: | |
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6. Press the Find All button. The Found Results tab of the Repository pane will be populated with the list of folders
containing files with the string "consult".
Typesl Folders Found Results |
Viewby: (@) Folder Structure () Object Types

E% MFocal
- [0 C:\MFOCALS\MICROFOCALS (23)
[+ (23 C:\MFOCALS\MICROFOCALS\TESTS (1)

7. Expand the nodes to view the files and results
Repository

Types | Folders Found Results |

View by: (@) Folder Structure () Object Types
E% MFocal

F—'% C\MFOCALS\MICROFOCALS (23)

& [0 app-fd.cpy (2)

: @ appsaeen.ss (1)

E common_78. cpy {5}

© 01 ECII'ISLIHEI'It—FI'IEI'IU-OFI‘hDI‘I pic x.-line 8

~ move "Consultant Maintenance™ to Menu-Mame- line 17
* move spaces to consultant-menu-option- line 20
 perform until consultant-menu-option equals "g"- line 21
- evaluate consultant-menu-option- line 27

@l “consultantsadd” using- line 34
 consultant-menu-option- line 36

- cancel “consultantsadd™- line 37

 cancel “consultpopup®- line 33

- [E constmenu.ss (4)

- [18 consultants.cpy (2)

IT|IT|

8. Double clicking on a result will navigate to the relevant line of code and highlight it

ALALLELOLUN.

7 & MFocal ORKING-STORAGE SECTION.
=15 CH\MFOCALSWMICROFOCALS (23) OPY| "comman_ws.cpy”.
H X | 01 consultant-menu-option pic x.
0% app-fd.cpy (2) | inkage section.
[ appscreen.ss (1) copy| “common_Ink . cpy”.

BCREEN SECTION.

i
ol on_78.cpy (5]
_ Y( ) 0PY| “constmenu.ss”.

constmenu.chl (3) @
1 consultant-menu-option pic x.-line 8 | Eopy| “common_ss.cpy” .
move "Consultant Maintenance” to Menu-Name- line 17 PROCEDURE DIVISION using Ink-store-ir

ove |nk-name-of-store to Stgre-h
move spaces to consultant-menu-option- line 20 ove “Consultant Malntenance” to

9. CI|ck Vlew > Folders or Types. This takes you back to the main Repository Browser window.
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SearchPrDject Prepare  Analyze R
e Foldes

Types

ST Chart Viewer

You may also click the Folders or Types tab at the top left of the Repository Browser pane.

Exercise 4-3: Using the Repository Assistant

CA has a facility to allow for a quick search over the repository. With this ability, the user can type in any name in the
system; Program, Variable etc. and get a result list of all objects that match the search pattern (within Entity type). For
each object in the list, the user can “right click” and see the possible actions available for that object. User Preferences

contains the default options selections which can be modified.

1. From the Repository Browser, type a value into the Search field and click the Find icon i or press Enter.

2. Enter *help in the item to search for: input area.

Repository
Folders Types lLegacy Search l

*help
Time: 0.277 s Records: 437

X |

- % General
=15 ‘Program Entry Point (1)
MFOCALHELP
= % TrainingMicroFocals
-5 COBOL File {434)
+ 7] Dedaration {328)
[7 Paragraph {41)
(23 variable (54)
mfocalhelp.chl @
Copybook File (2)
@ apphelp.ss

-
-
-

= &
-
+- [ MFHELP. =3

Please note that prior to accessing this search you will need to turn on ALL options under User Preferences so

that your results will be the same as the ones on the left.

Right click on any object to see the available functions for that object. Options depend on entity type.

3. Right click on copybook apphelp.ss. You will see the options that can be selected for Copybooks.
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4. Right click on Query Repository and you can see the queries that are available for Copybooks.

=

Folders Types |Legaq-I Search I 7

I“help x q
Time: 0.277 s Records: 437

E‘% General

=& program Entry Point (1)

EE] MFOCALHELP

EI %TralnlnngcroFocals

9 COBOL File (434)

‘[ Dedaration (328)

‘[2 Paragraph (41)

‘[ variable (54)

=+ [y mfocalhelp.cbl @

&- @ Copybook File (2)

i Assign Business Mame
Assign Tags

Include Into Project
Open

Interactive Analysis

Properties

Query Repository » Dependent Sources

Diagrammer » Direct References (all)

Direct References (outgeing)
Direct References (inceming)

Used Sources

Legacy Source

5. Select Dependent Sources (sources that are dependent on this copybook). The results are displayed in the Edit /
View pane on the right side of the screen.

@ TrainingMicroFocals (TrainingMicroFocals) - Micro Focus COBOL Analyzer - [Dependent Sources] - O
@ Workspace Search View Project Prepare Analyze Reperts Options Window Help |_ H & H X
FE LI ERIEEEETE TR mz Bma >
Project: [T» T [rrainingMicroFocals EAIR-R A2

st @B A “l 21 B |Records 1-41 autof 41 total (Row=1 Col=7)

| |Object Type 1 Object Name 1 SourcePath 1 |Usage \ObjectType 2 \Obje:t Name 2 -
|__1|COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIncudedInCobal COoBOL ABC4400. cbl

2| COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COBOL constmenu.chl

| 3| COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COBOL consultantsadd. cbl
| 4|coPyBOOK apphelp.ss MICROFOCALSIMICROFOCALS IsIncudedInCobel COBOL consultpopup. chl
| 5|COPYBOCK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COoBOL consultsum, cbl
|__6|COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COBOL custmaint. cbl
|__7|COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COBOL custmenu.cbl
|__8|COPYBOCK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobol COBOL CUSTNXKIN. chl
9| copvBooK apphelp.ss MICROFOCALS\MICROFOCALS IsIncudedInCobol CoBOL custpopup. cbl
10| coPYBOOK apphelp.ss MICROFOCALSMICROFOCALS IsIncludedInCabol COBOL errpopup.chl
|_11|COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobal COBOL gencustid.cbl
|_12|COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS IsIndudedInCobal COBOL GenCustomers.chl
13| CoP DOK apphelp.ss

IsIndudedInCobol COBOL getconsults.cbl -
»

Syntax Table for POSIX Regular Expressions

‘ Syntax | Expression Description
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\ Marks the next character as a special character. "n" matches the character "n".
"\n" matches a linefeed or newline character.

Matches/anchors the beginning of line.

Matches/anchors the end of line.

* Matches the preceding character zero or more times.

+ Matches the preceding character one or more times.

. Matches any single character except a newline character.

(expression) Brackets or tags an expression to use in the replace command. A regular

expression may have up to 9 tagged expressions, numbered according to their
order in the regular expression. The corresponding replacement expression is \x,
for x in the range 1-9. Example: If (h.*o) (f.*s) matches "hello folks", \2 \1 would
replace it with "folks hello".

[xyz] A character set. Matches any characters between brackets.

[Mxyz] A negative character set. Matches any characters NOT between brackets.
\d Matches a digit character. Equivalent to [0-9].

\D Matches a non-digit character. Equivalent to [*0-9].

\f Matches a form-feed character.

\n Matches a linefeed character.

\r Matches a carriage return character.

\s Matches any white space including space, tab, form-feed, etc. but not newline.
\S Matches any nonwhite space character but not newline.

\t Matches a tab character.

\v Matches a vertical tab character.

\w Matches any word character including underscore.

\W Matches any non-word character.

\p Matches CR/LF (same as \r\n) to match a DOS line terminator.

monon

NOTE: You can search text that contains special characters ("\", "A", "S" "+" " "and brackets) by entering preceding back
slash before each special character. For example, expressions "A + B is *C" and "C + D at *@" will match to the pattern "\D
\+\D .. \*"\D".

Within your repository, you can add annotation to an object for clarification or informational purposes. This can be very
useful to share information among multiple users of COBOL Analyzer.

1. From the View menu, select Object Information. You will see the Object Information pane.
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@ Workspace Edit Search | View | Project Prepare Analyze R
|& mEh s Ty o
T ———— ypes
J Project: I d — Refresh Browser F5
Chart Viewer
Folders Types | Refresh Chart Wiewer
ISear:h workspace Custom Report Results F3
Object Information  F2
El% TrainingMicroFocals Activity Log Ctrl+L
=] @ COBOL File Entire Workspace Ctrl+W
ABC4400.cbl @ :
autosetup.chl @ Getting started
' autosetup_test.ch Properties F4
H I Y e T

Notice the new pane that appears. This new pane will display any information that we wish to use to describe
this object.

I 0 B e | |

tnnmun chl &
L jcunsultantsadd.cbl (1 node selecte

_ | o

createstores.chl @

custid.chl @

. custmaint.chl @ W
Object Information |

2. Right-click on custmaint.cbl and select Properties. You will see the Properties dialog box into which you can
make annotations or add information about the selected object.
3. Click the Description tab.

Micro Focus COBOL Analyzer - Properties of custm... n

Statistic Relationships I Object Tags
Description General I System I Internal
y COBOL File
custmaint.cbl

Open oK Apply
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4. Inside the description field, type Customers maintenance. This information is internal to the tool, but when
provided can be a valuable asset to entry level programmers or staff who are unfamiliar with this program.

5. When you are finished, press OK. Notice the new information that appears in the Object Information pane (you
may need to reselect custmaint.cbl or press F5 to refresh this screen). You can use this to add Comments or any
other vital information necessary for your Project.

Customers maintenance

Exercise 4-5: Querying the Repository

Within your repository, you can quickly perform queries to return information about relationships between objects in
the repository. This can be very useful to provide high level impact analysis on your legacy objects or answer basic usage
questions.

Querying the Repository can quickly identify high-level relationship information across legacy objects. It can be used to
answer basic questions developers have about their system, especially regarding related components which can be
affected by a change.

1. Return to the Repository Browser select consultpopup.cbl.

2. From the Search menu, select Query Repository and then Used Sources. Opens and runs the Repository Query
tool and runs ‘Used Sources’ query. Notice the available queries for the Cobol File type. This menu is context-
sensitive, meaning that the queries will differ based on the file type that you choose.

':l Training (Training) - Micro Focus Enterprise Analyzer— -

Workspace | Search | View Project Prepare  Analyze Reports  Options  Windoy
| B EE Query Repository 4 Dependent Sources
Project: |— Direct References (all) i
5 @4 Search Criteria . .
b o Direct References (outgoing)
g4 Mew Criteria i i .
Folders TyR Direct References (incoming)
Legacy Search
Search wol ki L= el
Used Sources
-5 Cobol File Legacy Source
+ ARTI00.chl @
+ ART200.cbl @ Diagrammer Scopes 4
+ AR7300.cbl @ =
SRS CUSTING 1.ccp -
+ CUSTMNT 1.ccp @ 3
+ D— MECTETORE CRI @

Notice the new report that appears on the right. This pane will display the results of the Used Sources query. In
this case, it returned the copybooks used by our selected program.
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Object Type 1 |Object Mame 1 \Sourcepath 1 |Usage |ObjectTypa 2 |Object Name 2
_1|coBoOL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK apphelp.ss
_2|cosoL consultpopup.chl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. common.cpy
_ 3|coBoOL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. common_78.cpy
_ 4|coBoL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. common_ex.cpy
_5|coBoL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK common_Ink.cpy
_6|CoBOL consultpopup.chl MICROFOCALS\MICROFOCALS Indudes COPYBOOK common_ss. cpy
_ 7|cosoL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK COMMON_Ws.cpy
__8[coBoL consultpopup.chl MICROFOCALS\MICROFOCALS Indudes COPYBOOK consultants-fc. cpy
_g|cosoL consultpopup.cbl MICROFOCALS\MICROFQCALS Indudes COPYBOOK. consultants.cpy
_10{CoBOL consultpopup.cbl MICROFOCALS\MICROFQOCALS Indudes COPYBOOK consultpopup. ss
_11|coBOL consultpopup.chl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. dataflow.cpy
_12|COBOL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. lowerpopup. ss
_13|CcoBOL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. menuheader. ss
_14|coOBOL consultpopup.cbl MICROFOCALS\MICROFOCALS Indudes COPYBOOK. stores.cpy

15| COBOL consultpopup.chl MICROFOCALS\MICROFOCALS Indudes COPYBOOK chltypes.cpy

3. Right-click on an object in the results pane. You will see different options to perform on your results. You can
include these results in other projects and perform other queries on the resulting set in the Query Repository.

| usage |Object Type 2| Object Name 2 | SourcePath 2

Includes COPYBOOK apphelp.ss MICROFOCALS\MICROFOCALS
Includes COPYBOOK con ramsmassssslusenessaALS
Indudes | COPYBOOK con Edit LS
Includes COPYBOOK con| ALS
Indudes  COPYBOOK con Copy LS
Includes COPYBOCK o Delete ALS
Includes COPYBOOK con| Include into Project ALS
Includes COPYBOOK. con ALS
Incudes  COPYBOOK con (B s g = laLs
Indudes COPYBOOK con Assign Tags ALS
Includes COPYBOOK dat] ALS
Includes COPYBOOK low| Interactive Analysis ALS
Includes COPYBOOK i Show in Repasitary Browser ALS
Includes COPYBOOK. stol ALS
Incudes COPYBOOK chlt Properties

Query Repository 3 Dependent Sources

Direct References (all)

Direct References (outgoing)
Direct References (incoming)
Used Sources

Legacy Source

We can also perform Query Repository on multiple objects using the Ctrl / left click on each object. Additionally, you
can select the folder or project level to perform queries on an entire folder (all COBOL files) or to query against the
entire Project.

Query Repository can be used to quickly identify high-level relationship information across legacy objects. It can
be used to answer basic questions developers have about their system, especially regarding related components
which can be affected by a change.

Exercise 4-6: Querying Repository Workspace Objects

Some folders are only available at the workspace level. In the Training workspace, table relationships were created as a
result of parsing the sources that reference those tables. The ? indicates that the Create Table DDL does not exist in the
Workspace. View / Entire Workspace and expand the Table folder. We will use the existing table to find which
program(s) access the table and how it is accessed.

1. With the SYSTEMMESSAGES table selected, right-click and select Query Repository > Is CRUD BY. This will open
and run the CRUD (Create, Read, Update, and Delete) query for tables.
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+-[7] System Program
=24 Table

+ [ patarLow [@

] Sareen ‘
- B sysTEMMESs AcEs: [)

= % TrainingMic| Query Repository 4 Dependent Sources
o iﬁ B:EL Custom Reports Direct References (all)
5 aul Select 3 Direct References (outgoing)
Expand Subtree Direct References (incoming)
Show in Folders/Types view Is Called by
Assign Tags Is CRUD by

Add Files to Warksnare... Lz Sz

This is a very useful query to run in a production environment when you are interested in identifying all table
access within your application. The report below can be saved by using the report icon above the List pane.

Object Type 1 |Objeu:t Name 1 |Re|atiu:unship |Objeu:tT\,f|:ue 2 |O|:uject Mame 2 |SourcePaﬂ1
i TABLE SYSTEMMESSAGES IsInsertedIn COBOL ABC4400.chl MICROFOCALSYMICROFOCALS
2| TABLE SYSTEMMESSAGES IsReadIn COBOL mfocal. chl MICROFOCALS\MICROFOCALS

In the View Pane on the right side of the screen, you will see that table SYSTEMMESSAGES is read by mfocal.cbl
updated in ABC4400.cbl.

2. When you are finished, close the workspace view by pressing CTRL+W.
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Module 5: Working with Projects

It is useful to create additional projects in a workspace when you want to break large source deliveries down into
subsystems, either to partition work into more manageable units, or to perform separate analysis exercises on partial
subsets of sources.

When breaking a system down into separate workspaces and projects, it is important to first understand the
relationships between the two containers. When a workspace has multiple projects, objects in one project can still
recognize objects in another project. Therefore, some relationships and workspace-wide features will still apply across
all projects in a workspace. However, relationships do not exist across different workspaces. One workspace is
completely independent of another workspace. In addition, you can only work with one workspace at a time within
COBOL Analyzer. Understanding these relationships can be crucial in proper management and partitioning of an
application portfolio in COBOL Analyzer.

Also, only verified files have the object relationships defined that enable you to include referenced or referencing
objects in a project to ensure a closed system. You can include all referencing objects or only “directly referencing”
objects: If program A calls program B, and program B calls program C, A is said to directly reference B and indirectly
reference C. You can also remove unused support objects.

While currently there is no automatic recognition of Visual COBOL projects in COBOL Analyzer, it is very useful to create
the corresponding projects to match the Visual COBOL setup. In this way, the analysis information can help you assess
potential impact across the entire workspace (cross Visual COBOL projects) and highlight missing dependencies in your
different projects.

For customers who are exploring migrating to Visual COBOL, it is highly recommended to first break the source
deliveries down into project as mentioned in the introduction and then create the matching projects in Visual COBOL
(for Visual Studio or Eclipse).

It is also recommended to run the Migration Report that will include useful information for planning and executing such
a migration (See module 6 — Working with reports for more details).

A key feature of COBOL Analyzer is the ability to analyze the code you are currently working on (working copy). This
allows a developer to analyze the code before and after changes and fixes and assessing the impact of those changes
before committing the code.

While you can choose your favorite method of code editing, being it a simple text editor or an advanced Integrated
Development Environment (IDE) such as Visual COBOL, the source synchronization feature will allow you to keep your
analysis up to date with you working copy.

Source synchronization is achieved by several methods depending on your settings (Options—>Workspace
options—>Registration tab—>Source Synchronization tab:
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n Options - Workspace E1

4 General ' Registration |§ !eriﬁaﬁonl B4 system Prograrnsl 23 uomonymsl B Glossary | Search Assistant I
Extensions | Source Files |

—Source Synchronization

T Chedk for outdated sources automatically
rInterval

" Perform check periodically

Interval in hours: IlD

LL

% Perform check at a specific time

Perform check at: Ill:DU:DD PM j

T Execute batch file before synchronization

Batch file: | _I

[~ Synchronize the workspace after checking for outdated sources without asking me
¥ Unregister deleted files from the workspace

QK | Cancel | Apply

The Execute batch file before synchronization can be used for copying code, updating from source control,
preprocessing etc.

Once you have returned to COBOL Analyzer after making code changes in another tool, you can run the source

T+

synchronization from Workspace—>Source Synchronization or using the toolbar button ( — )

You’ll get a message box with information regarding the changed files:
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Source Synchronization

1 updated, & added files detected.

Mote if there are updates to include files that are used by many programs,
thiz could be a loang running process to re-analyze all the dependent files.

Do yvou want to synchronize the workspace?

Show Changes Yes Mo |

Modified Source Files “

Source

C\Workl\EA\CADEMO/MicroFocals\ABC4400.cbl

C:Work EACADEMO/MicroFocalsitests\autosetup_test.chi
C\Work EA\CADEMOIMicroFocalsitests\console dir

C\Work EA\CADEMOIMicroFocalsitests\custread.cbl

C:Work EACADEMO/MicroFocalsitests\dateinfo_test.chil
C:Work EACADEMO!MicroFocalsitests\gechashenc_test.chl
CWork EACADEMO/MicroFocalsitests\getdefstore_test chl
C:Work EACADEMO/MicroFocalsitests\getonestore_test.chl
C:Work EACADEMOMicroFocalsitests\splitline_test.chl

Close

Importing analysis data into Visual COBOL for Eclipse

In Visual COBOL for Eclipse, you can import code searches results from COBOL Analyzer into the IDE.
In order to add this capability, you'll need to install the COBOL Analyzer Eclipse plugin by following the instructions in the
COBOL Analyzer installation folder under docs.
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When you perform code searches in COBOL Analyzer, you create a list of Point of Interest (POI). These lists can be
imported to Eclipse allowing you to continue the development work inside the IDE by quickly navigating the results and
make the necessary changes.

More information about code searches and importing them is available in module 7 — Working with Analysis Tools.

Exercise 5-1: Create New Projects in a Workspace
Objective: You will create a new project in a workspace

10. Click Project on the menu and select New Project. You will see a screen similar to the following:

(2] Micro Focus COBOL Analyzer

e newProjectreme
Cancel

2. Inthe Enter New Project Name text field, type MainLogic. The project name must be unique within the
workspace, so, in a multiuser installation, it is preferable to include a user id or change request number as part
of the Project name.

3. Press OK. You will see the new project appear in the Repository pane.

Repository x|
Folders Types ] W

|E gearch workspace O\

+ @ Warkspace

+ % TrainingMicroFocals

Exercise 5-2: Copying Sources between Projects

When you want to analyze subsystems separately, or partition a large system into smaller, more manageable units, it is
helpful to copy sources between two projects in the same workspace.

1. Inthe repository pane, right-click the COBOL file mfocal.cbl from the Training project and select Include Into
Project.
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L gettimeslot.chl @

S mfocal.cbl i

4 getstoresnear.chl (2) ‘ ‘

.

e

4 mfocalhelp. Verify

# gy n.chl @ Interactive Analysis

' 4 reqappoint.

- [y schedread. Open

- [y schedulea .

_ : serui::eﬂa; Cuery Repository 3
- Lgh setadismod Custom Reports

=+ [y setrestmod

' 4 setstore.ch Select g
- [gy setstorel.d Expand Subtree

4 splitine. bl

Show in Folders/Types view

Assign Tags

Add Files to Workspace...
Refresh Sources from Disk

Delete from Workspace

Include into Project

Exclude from Project

@ Select Project El

% MainLogic Mew
% TrainingMicroFocals

Cancel

il

¢ iInclude All Referenced Objects:

[T Indude All Referencng Objects

+ Copy
= Move From Current Project

(= Move From All Projects

NOTE: Copy does not create a separate instance of the object but rather a “link” to the object. Changes made to a
file in one project will also be made in the other project. Move will remove the object from the 1°* project. Include
All Referenced Objects will also include all “child” objects related to the selected object.
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2. Inthe Select Project dialog box, check the Include All Referenced Objects checkbox and ensure that the Copy
option is selected. This ensures that all legacy files associated with mfocal.cbl are imported along with the
COBOL file itself. In this example, Copybooks and referenced programs have also been copied over into the new
project.

SRS MainLogic|
-3 COBOL File

+ ABC4400.chl @
centertext.u:bl @
cnnshﬂenu.d:ul @
cnnsultantsadd.-:bl @
cnnsulu:u:upup.n:bl @
u:-:unsultsum.d:ul @
cush‘naint.d:ul @
custmenu.chl @
u:usu:u:upup.d:ul @
dateinfo.chl @
Errpu:upup.u:l:ul @
gencustid.chl @
geohashenc,chl @
getconsults.chl @
getdefstore.chl @
getonestore, chl @
gettimeslot.chl @
mfocal.chl @
mfocalhelp.chl &
schedread.cbl @
scheduleapp.chl @
m setadismode.chl @
e storemaintenance.chl @
storepopup.chl @
valdate.chl @

[ Copybook File

- [E3 Program
+- [ Sereen

R P T T

+-&#-F-F-F-F-F-F-5-55 555555555522 E

3. Click Project > Toggle Sharing.

&

—-1-&§ COBOL File

4. Press F5 to refresh the Repository Browser. This option enables newly created Project to be viewable by other
users accessing the Workspace. You will see a hand icon to denote that the project is now shared.
5. To disable project sharing, select Project > Toggle Sharing.
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NOTE: If you select Toggle Protection, it prevents anyone (including yourself) from changing the contents of a
project (including or excluding objects). It also prevents you from accidently deleting your project (since you must

first unprotect it).

Exercise 5-4: Deleting a Project from a Workspace

A project can be removed from the workspace while preserving the legacy objects in the repository. If two projects
contain the same legacy source file, and one of the projects is deleted, the source file is not removed from the
workspace but rather “unlinked” from the deleted project. It may be desirable to remove a project to reduce clutter in

the workspace.
Objective: You will remove a project from a workspace

1. Perform the previous exercise but give a different name to the new project.
2. Select the new project.

NOTE: The Delete Project operation will be applied to the active project, so make sure the correct project has been

selected.

3. Onthe menu bar, click Project > Delete Project.

@
@' Workspace Search  View Prepare Analyze Reports Opt
|3 1 R [ B B B NewProject

Proiect: ,7 Delete Project
roject Toggle Sharing
Toggle Protection
Folders Types
% Copy Project Contents
Search workspace %% Empty Project Contents
Include All Referenced Objects
=8 erspce Include All Referencing Objects
H % MainLogic

¥ % TrainingMicroFocals Include Directly Referencing Objects

Compact Project

4. When you are prompted to delete the current project, press Yes. The objects in the deleted project will not be
deleted from the workspace. They will be “unlinked.” The objects will remain in the workspace and in any other

projects in which they are located.

Summary
In this module you learned:

e How to create new project in a workspace
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e How to copy sources between projects

e How to filter projects using the repository browser

e How to delete a project from the workspace

e How to keep your analysis data up to date with your working copy of the code

Page 45 of
Micro Focus, LTD. 2019 53



COBOL Analyzer Tutorial

Module 6: Working with Reports

Introduction

COBOL Analyzer includes tools for creating a variety of reports with useful information about your projects and
workspaces.

Obijectives

e You will learn how to create an inventory report
e You will learn how to create various kinds of reference reports
e You will learn how to create a portability assessment

Exercise 6-1: Create an Inventory Report

The Inventory Report contains high-level statistics on the contents of the current work-space. This includes the
Workspace folder, a sum of all projects and a section for each project defined to the workspace.

Objective: You will create a new inventory report

11. On the main menu bar, click Reports > Inventory Report.

TrainingMicroFocals

ze | Reports | Options Window Help

P ventor Report |

Verification Report
g CRUD Report

ﬁ? Reference Reports
B Complexity

You will see a screen similar to the following that lists a project for each user.
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® Inventory Report - TrainingMicroFocals (TrainingMicroFocals) -0 “
File View Help

Type Source Lines Quantity Unverified Verified | Erroneous | Relaxed Missing
COBOL File 10,184 79 71 1 7
% copybook File 3,310 56 56 1
=] Directives File for Checker

All Projects & Total 13,494 135 54 71 1 7
[2y coBoL File 10,184 79 71 7
1% Copybook File 3,310 54 54
=] Directives File for Checker 2

Project & MainLogic 7436 75 50 25
COBOL File 4,226 25 25
[% copybook File 3,210 50 50

Project 3§ TrainingMicroFocals 12,726 133 52 71 1 7
COBOL File 10,184 79 71 1 7
[ copybook File 2,542 52 52
EI Directives File for Checker 2

NOTE: Source lines, number of objects and the verification status and count is stored for each ‘source’ folder in
each project, ‘All’ projects and for the workspace.

12. When you are finished, close the Inventory Report by clicking the X in the upper right-hand corner.

Reference Reports

In any analysis or modernization project, it is important to ensure that no critical source components are missing or
unused. The cost/risk associated with a missing source component can be very high. This is a powerful way to validate
the completeness of your production code, confirm that all code is the most recent, and increase the efficiency of your
production code by removing any unused components.

There are four types of reference reports:

are missing copybooks.

Unreferred Report — Identifies unreferenced (unused) entities. This may or may not indicate that an object is
obsolete, based on what we have loaded in the workspace.
Unresolved Report — Identifies missing entities. Typically, at the onset of a deployment of CA, we find that we

Cross-Reference Report — Identifies all object relationships the system.

External Reference Report - Identifies references in object-oriented applications to external files that are not
registered in the workspace, such as .java, Java Archive (JAR), or C++ include files (assuming you have identified
the locations of these files in the Workspace Verification options window for the source files). These references
are not reported as unresolved in the Unresolved Report.

All reports have the same options and functions. For the sake of brevity, we will only perform the Unreferred Report
exercise. However, the following steps apply in the same manner to the Unresolved, Cross-Reference and External
References Reports.
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Exercise 6-2: Create an Unreferred Report

This report shows source components that are registered in the repository but that have no references elsewhere. For
example, copybooks are not used in programs, program entry points are not called or executed in JCL or invoked by a
transaction.

In general, all unreferred components should be investigated to ensure they have not been included by mistake, or that
the component using them (e.g., COBOL program) is not missing.
Various preprocessing methods should be also taken into account when analyzing this report.

Objective: You will create a new unreferred report

1. click Reports > Reference Reports.

@

Eile

Object View Help

| Report Type:

Unreferred Report
Unresolved Report

Cross Reference Report
External Reference Report

2. From the Report Type drop-down box, select Unreferred Report.
3. Close the Preview pane by clicking the X in the upper right-hand corner. Make sure you click the X in the
Preview pane and NOT on the Reference Reports window. You will see a reference report similar to the

following:
® Reference Reports - Focals (T ocals) - oEN|
| File Object View Help |
] Report Type: [Unveferred Report RNt E R Included Entity Types: i BB R E @@ &L !
Object Name | Object Type | Legacy Object | source W
JABC4400.FILLER Screen m ABC4400.chl SOURCES WMICROFOCALS MICROFOCALS\ABC 4400.CBL
EBlasca400.G-aPPrELP Sareen [ ABC4400.cbd SOURCES\MICROFOCALSMICROFOCALS\ABC4400.CBL
[ElauToseTue_TesT Program [ autosetup_test... SOURCES\MICROFOCALSMICROFOCALS\DATA\AUTOSETUP _TEST.CBL
[ElauToseTup_Test Program [ autosetup_test... SOURCES\MICROFOCALS\MICROFOCALS\TESTS\AUTOSETUP._TEST. CBL
E5]auTosETUP _TEST Program Entry Point [gy autosetup_test... SOURCES\MICROFOCALSWMICROFOCALS\DATA\AUTOSETUP_TEST.CBL
ESlauToseTup_TEST Program Entry Point (g autosetup_test...  SOURCESMICROFOCALS\MICROFOCALS\TESTS\ALTOSETUP_TEST.CBL
[Elcacotest Program [y cakcdtest. i SOURCES\MICROFOCALSMICROFOCALS\.OCATION. SERVICES\CALCDTEST.CBL
y* JCALCOTEST Program Entry Point % calcdtest.cbl SOURCES \MICROFOCALS \MICROFOCALS . OCATION. SERVICES \CALCDTEST.CBL
CCI.OOQP Program cdookup. chl SOURCES MICROFOCALS \MICROFOCALS\CCLOOKLP. CBL.
Elcaoone Program Entry Point (g cdookup.cbl SOURCESMICROFOCALS WMICROFOCALS \CCLOOKLP. CBL
[EJCOBOLUNITTEST. CONFIGTESTS Program [ ConfigTests.cbl  SOURCES\MICROFOCALS MICROFOCALS \SERVICES \STORES. UNITTESTS \CONFIGTESTS. CBL
EE]COBOLUNITTEST. CONFIGTESTS Program Entry Point [gh ConfigTests.chl  SOURCES MICROFOCALS\MICROFOCALS\SERVICES \STORES. UNITTESTS \CONFIGTESTS. CBL
ECWFMB\ Screen constmenu.cbl SOURCES MICROFOCALS WMICROFOCALS \CONSTMENU. CBL
ECW.G'W Screen m constmenu.cbl SOURCES \MICROFOCALS MICROFOCALS \CONSTMENU. CBL
cm.umrsm.mm Screen % consultantsadd.... SOURCESMICROFOCALS \MICROFOCALS\CONSULTANTSADD. CBL
|CONSULTANTSADD. G-APPHELP Screen % consultantsadd.... SOURCESMICROFOCALSWMICROFOCALS\CONSULTANTSADD. CBL
BBl cONSULTPOPLP. FILLER Sareen [ consuitpopup.chl  SOURCES\MICROFOCALS MICROFOCALS \CONSULTPOPLP, CBL
BBl CONSULTPOPUP. G-APPHELP Sareen [ consuitpopup.chl  SOURCES\MICROFOCALS WMICROFOCALS \CONSULTPOPLP. CBL
Bl CONSLLTPOPUP. G MENUHEADER Saeen [2 consuitpopup.cbl  SOURCES MICROFOCALS WMICROFOCALS\CONSULTPOPUP. CBL
CM.I.TRENJ Program % consultread.cbl SOURCES MICROFOCALS WMICROFOCALS\DATA\CONSULTREAD, CBL
gcousumw Program Entry Point & consultread.cbl SOURCES MICROFOCALS \MICROFOCALS\DATA\CONSULTREAD, CBL
[EBlCONSULTREAD FILER Sareen consultread.cll  SOURCES\MICROFOCALS MICROFOCALS\DATA\CONSULTREAD, CBL
BBl cONSLLTREAD. G-APPHELP Sareen [ consuitread.cbl  SOURCES\MICROFOCALSMICROFOCALS\DATA\CONSULTREAD. CBL
CG{SLI.TRENJ G-MENUHEADER Scareen % consultread. cbl SOURCES MICROFOCALS MICROFOCALS\DATA\CONSULTREAD. CBL
[EBICONSULTSUM.FILLER Sareen [3 consuitsum.cll ~ SOURCES\MICROFOCALS\MICROFOCALS\CONSULTSUM.CBL
Bl consuLTSUM.G-APPHELP Screen [2) consultsum.chl ~ SOURCES\MICROFOCALSWMICROFOCALS\CONSULTSUM.CBL
EG.EATKTG?ES Program % createstores.cbl SOURCES WMICROFOCALS WMICROFOCALS\DATA\CREATESTORES.CBL
 |CREATESTORES Program Entry Point % eatestores.chl SOURCES \MICROFOCALS WMICROFOCALS\DATA\CREATESTORES. CBL
[EBICREATESTORES. FILLER Saeen eatestores,chl  SOURCES\ICROFOCALS MICROFOCALS\DATA\CREATESTORES. CBL
BBl CREATESTORES. G-APPHELP Sareen [3 ceatestores.cil  SOURCES\WICROFOCALS WMICROFOCALS \DATA\CREATESTORES. CBL
EBICREATESTORES. G-MENUHEADER Saeen [ createstores.chi  SOURCES\ICROFOCALS MICROFOCALS\DATA\CREATESTORES. CBL
Elcusto Program [ custd.col SOURCES \MICROFOCALS \MICROFOCALS \DATA\CUSTID. CBL
ESlcusto Program Entry Point [gy custid.cbl SOURCES \MICROFOCALS MICROFOCALS \DATA\CUSTID. CBL
EScusTo R Screen [2 custd.cbl SOURCES\MICROFOCALS WMICROFOCALS\DATA\CUSTID.CBL
EBcusTo.G-aprrELP Screen [ custd.cbl SOURCES \MICROFOCALS \MICROFOCALS \DATA\CUSTID. CBL
B~ < .- aTAD AT PO 12 i /% ©CESWMICDNEN Al SWMTFDOEAC Al SINATAV 1T o N
< >
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4. To sort the Source column, click on the Source column header.

5. From the menu bar, click View > Options. You will see the Options — Reference Reports dialog box. From here
you can limit the file entities shown in the report, such as Copybook files and screens.

Entities
[~ select Al

(B Options - Reference Reports

mCop ybook File

&b Data Store

=
L |PL/SQL Script
Program

I Program Entry Point
O sceen

E=system Program
[EfTable

-

-

|

oK

Cancel

Apply

6. Inthe Options — Reference Reports dialog box, uncheck the Screen entity and press OK. In the reference report,

you will see that all the screens are no longer displayed.

7. Click the Copybook File icon on the INCLUDED ENTITY TYPES toolbar next to the drop-down box. The screens

should appear in the report again.

Included Entity Types: | By | C% == &

8. To create a reference report suitable for delivery to a customer, from the menu bar click File > Report... You can

also click the Report icon shown below.

You will see a screen similar to the following:
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O LC Report: Unreferred Report = b
~
Unreferred Report
Object Name. Qoect | ) egacy Object
Type
AUTOSETUP_TEST Program |autosetup test.cbl |SOURCESWICROFOCAL
AUTOSETUP_TEST Program |autosetup test.cbl |SOURCES\WWICROFOCAL
AUTOSETUP_TEST Program |autosetup_test.cbl [SOURCESWICROFOCAL
Entry
Point
AUTOSETUP_TEST Program [autosetup test.cbl |SOURCES\MICROFOCAL
Ent
Poir?{
CALCDTEST Program [calcdtest.cbl SOURCESWMICROFOCAL
CALCDTEST Program [calcdtest.chbl SOURCESWMICROFOCAL
Entry
Point
CCLOOKUP Program |cclookup.cbl SOURCESWMICROFOCAL
CCLOOKUP Program |cclookup.cbl SOURCESWMICROFOCAL
Entry
Point
COBOLUNITTEST.CONFIGTESTS Program |ConfigTests.cbl SOURCES\WMICROFOCAL
COBOLUNITTEST.CONFIGTESTS Program |ConfigTests_cbl SOURCESWICROFOCAL
< >
Page Setup Print Save Close

9. Either Save or Print the report using the appropriate buttons at the bottom of the dialog box. The default
location for any report or diagram that you save is the Output folder under the Workspace folder on the server.
You can override the Save in: to a network location or a local drive on your PC.

T ] |

Save jn: I@ Output j - ek B~

My Documents

3 ,

My Camputer

File name: [Unvetered Report for Training 20100715 = Save |

Saveastype: [ HyperTest Hle " bt im) =] Caricel
[HyperT et fils [ it htri]

N—

Rich test [t

w'ord document [*.dac)
Tt file [*.txt)

Plain CSV file [*.cs¥)

You can modify the report name to add your id and / or date so that the same report run multiple times will not
be overplayed. You can change the report type to any valid extension provided you have the supporting
software to open the file. The most useful format for most reports is Excel.
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10. When you are finished, close the Unreferred and Reference report windows.

Determining Complexity

An object’s complexity is based on weighted values calculated for selected file attributes. COBOL Analyzer produces a
complexity report to help managers and users determine the depth and complexity of their legacy system. The
Complexity Report displays metrics specific to the entity type selected. Better understanding of a legacy system’s
complexity will aid in predicting the effort and resources required to maintain, enhance, or transform the system.

COBOL Analyzer provides a combination of Micro Focus generated and Industry standard complexity statistics. For
COBOL “programs", the industry standard metrics used are based on Halstead and McCabe. The Halstead measure
(Program Volume) is based on operators and operands while McCabe or Cyclomatic Complexity is based on the number
of logical paths. Descriptions of these measures can be found in the Online Help.

Complexity Metrics show raw complexity values for source (i.e. COBOL) and generated (i.e. Program) files in your
project. Initially the Complexity Metrics window is empty. You must select the entity type for which you want statistics.

Exercise 6-3: Determining Complexity
Objective: You will create a complexity metrics report

1. Onthe menu bar, click Reports > Complexity.
2. Inthe Entity Type drop-down box, select COBOL File.

Entity Type: | (3 SoEENEE |
A Name (not selected) i

ABC4400. cbl A COBOL File| I

autosetup.chl @ Copybook File
centertext. cbl Screen
constmenu, cbl Program

3. Repeat Step 2 and select Copybook File. You will see the complexity statistics for your Copybooks.

4. Repeat Step 2 and select Program. You will see the complexity statistics for ALL of the Programs in the project
are displayed. Programs are the parsed version of COBOL, Java sources etc. Programs have many metrics
available.

5. Onthe menu bar, click View > Columns... You will see the Options — Program dialog box. The available metrics
for the chosen entity are displayed, and you can select the metrics that you want included in the report and on
the screen.
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(& Options - Program ﬂ

— Attributes —
Lines Of Code A
Executable Statements

Operators Lnselect all
Operands

Unigue Operators
IUnique Operands
Program Length
Vocabulary
Program Volume
Program Level
Programming Effort
Difficulty

Inteligent Content
Programming Time
Error Estimate p =l

Details, ..

Ok Cancel Apply

6. Select Program Volume, Cyclomatic Complexity, and any others of your choice, then click OK. You will see the
selected statistics for the programs displayed.

@ Complexity Metrics - TrainingMicroFocals (TrainingMicroFocals) = =
File View Help

| Entity Type: | |J |

A Name | Source Name | Program Volume | Cyclomatic Complexity I Dead Statements I Dead Data Elements I Dead Lines I ~

ABC4400 ABC4400.cbl 755.0700 L 103 182 431
AUTOSETUP_TEST autosetup_test.chl 53.1500 1 a a a
AUTOSETUP_TEST autosetup_test.chl 53.1500 1 a a a
CALCDISTAMCE calcdistance. cbl 303.0800 1 a a a
CALCDISTAMCE calcdistance. cbl 303.0800 1 a a a
CALCDTEST calcdtest. chl 155.5900 2 a a a
CCLOOKLP cclookup. cbl 300,0000 11 a 1 1
CENTERTEXT centertext.chl 413.4300 5 a 92 92
COBOLUNITTEST.CONFIGTESTS ConfigTests.chl 0.0000 1 a a a
CONSTMENU constmenu. chl 806.9300 ] 103 168 415
CONSULTANTSADD consultantsadd. cbl 6,461.5700 77 35 188 296
CONSULTPOPUP consultpopup.chl 1,665.8800 13 111 193 500
CONSULTREAD consultread. cbl 2,429.5900 55 59 199 355
CONSULTSUM consultsum. cbl 5,455.2000 62 43 188 321
CREATESTORES createstores, chl 7,880.5200 87 62 172 315
CUSTID custid.cbl 3,536.0700 57 59 470 605
CUSTMAINT custmaint. cbl 7,258.2400 g2 15 146 201
CUSTMENU custmenu.cbl 8857400 ] 103 161 407
CUSTMXKIM CUSTMXKIM, cbl 281.7500 1 123 184 473
CUSTPOPUP custpopup. cbl 5,936.6200 95 27 162 257
CUSTREAD custread.cbl 2,772.3200 58 59 471 606
CUSTREAD custread.cbl 3,271.2400 56 59 469 a4
DATEINFO dateinfo.chl 452.8900 7 a 93 93
DATEINFO_TEST dateinfo_test.chl 340.0800 1 a a a

7. Inthe Complexity Metrics pane, click on the Cyclomatic Complexity column header twice to sort the report by
descending order of complexity.
8. Create a Complexity Report:
e From the main menu click File > Report.
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LC Report: Complexity Metrics = =
[
Complexity Metrics
Name Source Name Program Cvcloma_tic Dead Dead Data M
- - Volume Complexity | Statements | Elements | Lines
GENCUSTOMERS gencustomers.chl 13,184.0600 159 36 216 336
GENCUSTOMERS GenCustomers.chl 9,834 5600 108 36 215 335
SCHEDREAD schedread.chbl 8,769.1100 99 48 176 298
SCHEDULEARPP scheduleapp.chl 7,912.4200 97| 15 184 248
CUSTPOPUP custpopup.chl 6,936.6200 96 27| 162 257
STOREPOPUP storepopup.chl 6,726.5800 89 18 134 187
CREATESTORES createstores.chl 7,880.5200 87| 62 172 315
CUSTMAINT custmaint_cbl 7.256.2400 82 15 146 201
CONSULTANTSADD consultantsadd_cbl 6,461.5700 77| 35 188 296
REQAPPOINT regappoint.chbl 4,459.0100 72 63 231 393
STOREMAINTENANCE storemaintenance chbl 4.,937.1200 70 15 146 194
DELAPPOINT delappoint.chl 3,724 2200 67| 59 235 408
GENCONSULTS genconsults.chbl 3.624.0200 65 95 177 344
CONSULTSUM consultsum.chl 54552000 62 48 186 321
GETDEFSTORE getdefstore. chl 2,743.2900 62 53 259 39
GETSTORESMNEAR getstoresnear.chbl 3,203.0400 62 59 268 413
GETONESTORE getonestore chl 2,783.1000 61 45 264 388
GETSTORES getstorelimit.chbl 2.,602.7200 61 90 268 426
GETCONSULTS getconsults.chl 3.070.5200 60 59 295 459
GETCUSTOMERS getcustomers._chl 2,660.0400 60 59 451 599
GETSTOREINFO getstoreinfo.chl 3,174.8400 59 61 176 325 W
GETSTORES getstores.chl 2.797.7000 59 90 174 330
Page Setup | Print Save Close
A

9. Close the Report window by clicking the Close button.
10. Close the Complexity Tool by clicking the X in the upper right-hand corner.

In this module you learned:

e How to create an inventory report

e How to create an unreferred reference report

e How to create a complexity report

Next steps

Click the Save button to save the report. Save in any format you wish.

You have concluded the getting started part and should have the basic understanding of COBOL Analyzer concepts. You
can now start using the various analysis features using the getting started pane (View—>Getting Started) or the different

menus.

We encourage users to continue the tutorials found in the Micro Focus community site to explore the different analysis
capabilities of COBOL Analyzer.

Micro Focus, LTD. 2019

Page 53 of

53


http://community.microfocus.com/microfocus/cobol/cobol_analyzer/

