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Bonus Resources 
As an extra bonus, additional Microsoft Excel resources, a keyboard shortcuts handout, 
and other helpful tips are waiting for you at: 
 

TheSoftwarePro.com/Excel 
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Linking Excel Data 
Some of the most useful and time-saving features in Excel are the options to link multiple 
worksheets together and linking to data in other workbooks and sources. 

Linking Within a Workbook 
Do you have a workbook with related data such as separate worksheets for individual 
months or different locations? How do you create a summary of these detailed 
worksheets? The most common type of link in Excel is also the easiest, that is, a reference 
to a value in a different worksheet in the same single workbook. 

Creating a Simple Link  
To create a link from one worksheet to another: 

1. Move to the cell where you want to see the result or link. 

2. Type =. 

3. Move to the location with the value or text entry and click on the cell. You are 
using the pointing method. 

4. If you want to build a formula with this value, such as adding it to another cell, 
type a math operator such as + or *. 

5. Repeat steps 3 and 4 above until you have completed your formula. 

6. Press J to complete the formula and link. 

To simply reference a value in another location, such as the Sales Summary below, do 
steps 1, 2, 3, and 6. 
 
 
 
 
 
 
 
 
 

The syntax for referring to cells in another worksheet is: 
=SheetName!CellAddress 

Here, SheetName refers to the name of the worksheet that provides the data, 
CellAddress is the name of the cell or range, and ! is the divider between the 
worksheet reference and the cell reference. In the example above, this is =Texas!I5. 
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You can also use this same approach (previous page) to create a reference in the 
same worksheet to a different location. For example, for easy reference at the top of a 
worksheet, create a link to a total at the end of the worksheet. 

 

3-D Formulas 
A 3-D formula refers to the same cell or range in multiple worksheets. For example, the 
formula =SUM(North:West!C15) sums the data in the C15 cells in the range of 
North:West worksheets. 

 

 

A 3-D formula requires that each worksheet contains the same type of data in the same 
location for each worksheet in the 3-D reference. 

Inserting a 3-D Reference 
To insert a 3-D reference into a formula: 

1. Enter the formula until the point where you need a value from another 
worksheet to complete the formula. 

2. Click on the first worksheet you want to refer to. 

3. While pressing V, activate the last worksheet you want to refer to in the 
formula. 

4. Select the cell or range containing the values you want the formula to refer to. 

5. Complete the formula and J. 
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Linking Across Workbooks 
Just as you can link multiple worksheets within a workbook, you can also link multiple 
workbooks. You do this by creating a formula in one workbook that refers to a cell, range, 
or name in another workbook. References to other workbooks are called external 
references. A workbook with the data is called a source workbook; the workbook with the 
links is called the destination workbook. You can maintain workbook links even if the 
workbook that is referred to is renamed. 

Why not just put all of the data into one workbook? In some cases, you can. But the real 
value of linking becomes apparent when the source workbook is being continually 
updated by another person or group. Creating a link in Workbook ABC to 
Workbook XYZ means that in Workbook ABC, you will always have access to the most 
recent information in Workbook XYZ because Workbook ABC is updated whenever 
Workbook XYZ changes. 

External Links 
Similar to creating links within one workbook, creating a link across multiple workbooks 
is much easier than you might think. Just as with any other formulas, start your formula in 
the cell where you want to see the end result. 

The syntax for referring to a cell in another worksheet in another workbook is: 
=[WorkbookName.xlsx]SheetName!CellAddress 

Here, WorkbookName refers to the name of the workbook that provides the data, and 
SheetName refers to the name of the worksheet in the source workbook. At the end of 
the formula, reference is the name of the cell or range, and ! is the divider between the 
worksheet reference and the cell reference. 

Here’s an example of a formula that uses cell G6 in the Sheet1 worksheet of a workbook 
named Colorado.xlsx: 

=[Colorado.xlsx]Sheet1!G6 

If the workbook name or sheet name in the reference includes one or more spaces, you 
must enclose the text in single quotation marks. For example, here’s a formula that uses 
cell H10 in the Sheet1 worksheet of a workbook named New Mexico.xlsx: 

='[New Mexico.xlsx]Sheet1'!H10 

When you use the pointing method as described on the next page, Excel will automatically 
add the single quotation marks as needed. 
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Creating a Link By Pointing 
Entering external reference formulas manually is usually not the best approach because 
you can easily make an error. Instead, have Excel build the formula for you. 

To create an external link: 

1. From the destination worksheet, select the cell where you want to enter the 
formula. In the example below, the destination worksheet is Sales 
Summary.xlsx. 

2. Select the cell where you want to enter the formula. 

3. Type the equals sign (=). 

4. Activate the source workbook and click on the cell in the source worksheet 
which contains the value you want to link to and reference in the formula. In 
the example below, the source worksheet is Colorado.xlsx. The worksheet 
name is Sheet1. 

5. Add other references from the source workbook and/or destination workbook 
to complete the formula. 

6. Press J to complete the link. 

 

 

 

 

 

 

As long as the source workbook remains open, the external reference doesn’t include the 
path to the workbook. If you close the source workbook, the external reference formulas 
change to include the full path. 

If you plan to copy the formula to create additional link formulas, you need to change the 
absolute reference to a relative reference by removing the dollar signs for the cell 
address. 
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Pasting Links 
Pasting links is another way to create external reference formulas. This method works 
when you want to create formulas that simply reference other cells. 

To create an external link by pasting: 

1. Open the source workbook. 

2. Select the cell or range you want to link and then copy it. 

3. Choose the dependent workbook and select the cell where you want the link to 
appear. 

4. Pick Home > Clipboard > Paste > Paste Link. 

Security Warnings 
By default, Microsoft Excel is configured to prompt you when a workbook that has 
external links requires those links to be updated. This is a security consideration that is 
intended to protect your workbooks from viruses and other malicious code. When you 
open a workbook containing external links that need updating, Excel displays a security 
warning, below the Ribbon. 

 

 

To enable the updating of links between workbooks: 

1. Click Enable Content in the security warning. 

2. Select Enable this content. Click OK. 

These are one-time actions which you will need to repeat every time the workbook is 
open.  

This default in Excel is to prevent automatic updating which could launch programs or 
install malicious viruses in linked files. In most work environments, virus scanning 
programs and other security measures are designed to protect against dangerous 
files. 

You can choose to enable links each time you open linked files or change your Excel 
options for handling linked content. When you are working with files you trust, your 
daily work will be much easier if links are automatically updated. 

Your agency security policies may prevent you from changing these options in Excel. 
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To enable the updating of links for all workbooks without prompts: 

1. Choose File > Options. 

2. Select Trust Center and then Trust Center Settings. 

3. Choose External Content and then check the option, Enable automatic 
update for all Workbook Links. Press OK until all dialog boxes are closed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Opening a File with Links 
When you open a workbook with external links, Excel will also prompt you to update the 
links. Choose Update if you trust the source and you want to see the most recent data. 
Choose Don’t Update if you want to see the previous information or you want to verify 
the external links. 
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Maintaining Workbook Links 
You can change the name of a workbook even if it is linked to another workbook. If both 
the source and destination workbooks are open, the link gets updated automatically. If 
you don’t have the destination workbook open, you can still redirect the links. You might 
also need to update links if a source workbook is moved or renamed. 
 
 
 
 
 
 
 
 

To redirect or update links: 

1. Activate the Data tab. 

2. From the Connections group, click Edit Links to open the Edit 
Links dialog box. 

3. Pick the source workbook whose links you want to update from 
the Source file list. 

4. Click the Change Source button to open the Change Source dialog box. 

5. Select the name of the new destination workbook which will be linked back to 
source workbook; this workbook will replace the previous workbook. Click OK 
to return to the Edit Links dialog box. 

6. Click Close to close the dialog box. 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
Click on Startup Prompt to specify how Excel handles links when the workbook is 
opened.  
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Breaking Links 
There are a number of reasons why you might want to remove or break the links in a 
workbook including: the project is finished, you want to preserve the data at a specific 
point in time, or you need to distribute the workbook via e-mail to people who are outside 
of your organization and do not have access to the source files. When you break links, the 
data values currently displayed in the destination workbook are retained but no further 
updating occurs from the original source workbook(s). 

To redirect or update links: 

1. If you want to keep the original workbook with its links intact, save the 
workbook to a new name which you can then distribute. 

2. Activate the Data tab. 

3. From the Connections group, click Edit Links to open the Edit Links dialog 
box. 

4. Select the first source workbook whose links you want to break or remove. 

5. Hold V and click on the last workbook in the list whose links you want to 
break. Or hold down C and click on each workbook individually. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Click on Break Link. 
 
 
 
 
 
 

7. Confirm you want to Break Links and click Close to close the dialog box. 
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Creating Hyperlinks 
Every time you click on a link in a web page or from an e-mail message, you are using a 
hyperlink. Like most Microsoft Office applications, Excel lets you create links. These links 
can take you to a place in the same worksheet or workbook, to a document created by 
another Office program, or even to a web page. You can even create e-mail address links 
so others can click a link to e-mail you or others listed in a worksheet. 

Liking to another file is different from paste linking. Instead of pulling Excel data into 
another program, a link lets you move from a worksheet to a related document, e-mail 
address, or web page. 

Automatic Hyperlinks 
Have you ever typed an e-mail address or a website address into an Excel list? Did it 
change to a blue link, often with a different font or size? If so, you created an automatic 
link using one of Excel’s AutoFormat as You Type features. If you are creating a long list 
of e-mail addresses, this is a handy feature because the links can easily be used to launch 
an Outlook (or other) message. If you don’t need the link and want the entries to look the 
same as everything else in a list, you may find this “feature” to be annoying. 
 
 
 
 
 
 
To enable or disable automatic hyperlinks: 

1. Click File > Options. 

2. Pick the Proofing category at the left and then choose the AutoCorrect 
Options button. 
 
 
 
 
 
 
 

3. Next, click the AutoFormat As You Type tab and check or un-check the option 
for Internet and network paths with hyperlinks. OK twice. 

 

 

  

Examples of automatic 
hyperlinks enabled or disabled 
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Inserting a Hyperlink 
To create a link to another source, you can also insert a hyperlink into an Excel 
worksheet. In addition to text, you can create links from workbook graphics such as 
shapes, pictures, clip art, and WordArt. 

To insert a hyperlink: 

1. Select the cell or graphic object where you want the link to appear. A link can 
be stored in a cell, a text box, or even a shape. 

2. Choose the Insert tab and pick Link to open the Insert Hyperlink dialog box 
or press C + K. 

3. Click a Link To location. This example uses Existing File or Web Page. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. At Text to display, type the text you want to display in the worksheet field. 

5. Pick the Look in location and select the location with the file you want the link 
to go to. Pick the file you want to link. 

6. Or enter or copy a web page address in the Address area. Click OK to finish. 

The cell or graphic content appears as a link. You can pass your mouse over the link 
without clicking to see the name of the linked-to file. 

To test a hyperlink: 

1. Left-click a link or right-click a link and pick Open 
Hyperlink from the shortcut menu. The linked-to 
document or web page appears. 

2. Close the linked document or page to return to your 
original worksheet. 

To edit a hyperlink: 

1. Right-click the link, and then pick Edit Hyperlink from the shortcut menu. 

To remove a hyperlink: 

1. Right-click the link, and then pick Remove Hyperlink from the shortcut menu.  

http://www.thesoftwarepro.com/
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Protecting Your Work 
By protecting a worksheet or workbook, you can prevent unauthorized users from 
modifying it. You can protect an entire worksheet or protect only a part of it, permitting 
users to alter the other parts. Although optional, applying password protection prevents 
other users from turning off the protection. Another option is to protect a workbook from 
changes to the structure or windows layout. 

 

 

 

Protecting a Worksheet 
When you protect an entire worksheet, all cells in that worksheet are locked by default. 
This means that users cannot change any of the cells when protection is enabled. To 
permit users to change some specific cells, you must unlock the cells manually before 
protecting the rest of the worksheet. Users can then change data in only the unlocked 
cells. The rest of the worksheet remains protected. For example, a worksheet might have 
unlocked cells to allow for data entry of values while locked cells contain formulas. 

Locked Cells Protection 
To protect only a part of a worksheet: 

1. Select the range of cells you want users to be able to modify. 

2. Right-click and choose Format Cells to open the Format Cells dialog box. 

3. Activate the Protection tab. 
 
 
 
 
 
 
 
 
 
 

4. Clear the Locked check box and click OK. 

5. Protect the worksheet with the steps on the following page. 
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To apply protection to a worksheet: 

1. Pick the Review tab. 

2. Click Protect Sheet. 

3. From the Protect Sheet dialog box, check the options you want. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Type a password and click OK. When the Confirm Password dialog box 
appears, type the same password again. 

5. Click OK to close all dialog boxes. 

 

Password Warning: If you have set a password, using that password is the only way to 
remove protection from the sheet. Passwords can be up to 255 characters, can include 
special characters, and are case sensitive-you will be prompted to type the password 
twice to avoid errors. 
DON’T FORGET YOUR PASSWORD! If you forget the password, you will not be able to 
remove protection from the workbook. 
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Protecting a Workbook 
Workbook protection prevents changes to a workbook structure and windows. 

To protect a workbook: 

1. Select the Review tab and click Protect Workbook in the Changes group. 

2. From the Protect Workbook dialog box, you can protect a workbook’s 
structure and window. 
 
 
 
 
 
 
 
 
 
 
By selecting Structure, you protect a workbook from being moved, deleted, 
hidden, unhidden, or renamed, and new worksheets can’t be inserted. 
 
By selecting Windows, you ensure a workbook’s windows are the same size 
and position each time the workbook is opened. To prevent other users from 
removing workbook protection, you can set a password. 

3. After specifying settings in the Protect Workbook dialog box, click OK. 
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Adding Comments 
Adding comments in Excel are helpful when you are reviewing a workbook, wish to add 
notations, or you send a file to someone else to review. 

Changing Your User Name 
Many Excel actions including creating a new workbook and comments also reference who 
performed the action. This identifier comes from the user name in Excel. 

Have you ever seen this type of message when you have tried to open a file? Who the heck 
is Your Company Name and who do you call to see if they are done working with the file 
you need? 

 

 
 

 

 

A typical installation of Microsoft Office in a large organization includes standard settings 
with a generic user name. To simplify sharing files and working with comments, revisions, 
and other features in Excel, personalize your computer user name and encourage 
everyone you work with to do the same. 

To change your user name in Excel: 

1. Click File > Options. 

2. Pick the General category at the left and enter your name in the Personalize 
your copy of Microsoft Office area. 
 

 

 

3. OK to apply the change. This new user name will also be changed in your other 
Microsoft Office programs. 
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Adding Comments 
A comment is a note or annotation you can add to cells or workbooks to provide 
additional information. Adding comments to data makes your worksheet easier for other 
users to interpret and gives you a way to add review notes to the workbook. 

To add a comment: 

1. Select a cell where you want to add a comment. 

2. Choose any of these actions to open the comment box: 

• Pick New Comment from the Review tab. 

• Press V + 2. 

• Right-click on the cell and choose Insert Comment from the shortcut menu.  
 

 
 

 

3. Your user name appears in the comment box. The red comment indicator 
appears in the upper-right corner of the cell. 

4. Enter the comment; you can delete the user name 
if you wish. As with other graphic objects, the 
comment box can be formatted and re-sized as 
you wish. 

5. Click outside the comment box to close it. The 
comment box disappears, but the cell displays the red comment indicator. 

These comments do not alter the data in the cell. Comments in cells are denoted by small, 
red triangles, called comment indicators, in the upper-right corner of the cells. 
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Viewing & Editing Comments 
To view a comment: 

1. Move your mouse to any cell with the red comment indicator in the upper-right 
corner; you don’t have to click on the cell. The comment will pop-up to display 
the contents. 

To show all comments simultaneously, activate the Review tab. 
Then, in the Comments group, click Show All Comments. Click 
the button again to hide all comments. 

To navigate to a comment: 

1. Choose Next or Previous from the Review tab. 

To edit a comment: 

1. Select the cell with a comment. 

2. Choose any of these actions to edit a comment: 

• Pick Edit Comment from the Review tab. 

• Press V + 2. 

• Right-click on the comment and choose Edit Comment 
from the shortcut menu. 

To delete a comment: 

1. Select the cell with the comment you want to delete. 

2. Pick any of these actions to delete the selected comment: 

• Pick Delete from the Review tab. 

• Right-click on the comment and choose Delete Comment from the shortcut 
menu. 

Printing Comments 
To print comments: 

1. Click Page Layout tab and then click the dialog launcher button in 
the Sheet Options group. This opens the Page Setup Sheet tab. 

2. Pick the drop-down for Comments and select how comments will be printed. 
For example, if you choose to Show All Comments (above) you might pick As 
displayed on sheet. 

3. OK to apply. 

 

 

 

 
Put these tips and techniques to practice and become more productive with Excel! 
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Tips, Timesavers & Takeaways 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Bonus Resources 
As an extra bonus, additional Microsoft Excel resources, a keyboard shortcuts handout, 
and other helpful tips are waiting for you at: 
 

TheSoftwarePro.com/Excel 
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Meet Dawn 
Dawn Bjork, MCT – The Software Pro® 

Software Productivity is Only a Click Away™ 
Dawn Bjork, MCT, is The Software Pro® with 25+ years' experience as a Software Navigator. 

A professional speaker, trainer, consultant, author, and 
business owner, Dawn simplifies complex processes with an 
informative and entertaining approach and delivers content 
that is immediately useful. Dawn has helped more than 
100,000 individuals from Fortune 500 companies, 
government, education, and other organizations to learn 
smart, easy, and productive ways to use software and 
technology more effectively. 

Microsoft has awarded Dawn with the certifications of 
Microsoft Certified Trainer (MCT), Microsoft Office Specialist 
Master (MOSM), and individual certifications in Microsoft 
Windows, Excel, Word, PowerPoint, Outlook, Access, OneNote, 
and Visio. In addition, The Software Pro is certified as a 

Women’s Business Enterprise (WBE) and Woman Owned Small Business (WOSB). 

Dawn is the Immediate Past President of the National Speakers Association-Colorado, the largest 
chapter in the country. When she’s not immersed in the world of software productivity, Dawn 
enjoys the Colorado mountains, hiking, biking, golf, yoga, playing poker, and spending time with 
her family. 
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