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— Getting Started —

Creating a webM ethods ApplinX Web Application

JSP

’ ? ’Creatinq an ApplinX Web Application using the Software AG Designer based on Eclipse (recommended)
B | Creating an ApplinX Web Application using JDK and Tomcat (no |DE)

.NET

B | Creating an ApplinX Web Application using Visual Studio 2005

B | Creating an ApplinX Web Application using Visual Studio 2008

’ 2 |Creatinq an ApplinX Web Application using .NET SDK 2.0 (no IDE)

B | Upgrading an ApplinX Web Application from Visual Studio 2003 to 2005

Creating an ApplinX Web Application using the Software AG Designer based on
Eclipse (recommended)

The following is based on the rel eased Eclipse version. Additional information can be found on Eclipse web site and WTP (Web
tool platform) site.

# To create a new Dynamic Web project you need to create a project, a server and a JRE (JDK)

1. Inthe Eclipse workspace, select File > New > Pr gject to create a new project.
2. Select Web > Dynamic Web Project.
3. Click Next to create a new J2EE Web project. The Dynamic Web Project dialog box is displayed.
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4.
5.
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& New Dynamic Web Project |z|@

Dynamic Web Project |
Create a standalone Dynamic Web project or add it to a new ar existing Enterprise Application, I @

Project name: |[

Project contents:
Use default

Target Funkime

|J2EE Runtime Library » | [Ngw... l

Configurations

!Default Configuration for JZEE Runtime Library » |

& good starking For working with JZEE Runkine Library runtime, Additional facets can later be installed ko add new
functionality to the project.

EAR Membership
[ add project to an EAR

Enter a name for the project.
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In the Target Runtime field, select the Tomcat installation: click New... and select the server to be used (Tomcat v 5.5).

Note:

Currently the Software AG common Tomcat cannot be used to create a Web application and you are required to install an

additional Tomcat 5.5 version.
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& New Server Runtime

MNew Server Runtime

Define a new installed server runtime environment

Rurtines are used at build time to compile projects.

Download additional server adapters
Select the runtime type:

lt_gpe filter bext |

=== Apache ~
- apache Tomcat v3.2
Apache Tomcat 4.0
Apache Tomcat wd.1
Apache Tomcat «5.0

IEEE] EETE] [E) ETE) EETE

Apache Tomca

Apache Tomcat 6.0

0
¥

HE
.
s

JZ2EE Preview
fj J2EE Runtime Library

i {1 ]

Apache Tomcat 5.5 supports J2EE 1.2, 1.3, and 1.4 Web modules,

154

Also create new local server

6. Click Next.

& New Server Runtime

Tomcat Server

Specify the installation direckory

Mame:

|_Ainache Tomcat v5.5 |

Tomcat installation directory:

| | [ Browse. ., ]

IJRE:

|W0rkbench default JRE V! [Lnstalled JREs... ]
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7. Browse and select the Tomcat installation from the Software AG installation directory: C:\Program Files\Software
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AG\Tomcat\cp8.0
8. Select aJRE or click Installed JREs... to add a new JRE. The Preferences dialog box is displayed.

& Preferences

=30 [nistalled JREs Installed JREs

Add, remove or edit JRE definitions, By default, the checked JRE is added to the build path of newly created Java
projects,

Installed JREs:

Mame Location Type Aadd...
Biv1.5.0 C:\Program Files\Software 4G 0KYw1.5.0  Standard WM

(7 [ 0K ] [ Cancel ]

9. Define the Runtime Environment (JRE) for the server: JSP server requires afull JDK and not only the JRE bundle. If you
need to add a new JRE, click the Add... button.
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10.
11
12.
13.
14.

15.
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£ Add JRE X
IRE bype: iSEﬂ_d;r_d Wi v :
JRE name: ! [ l
JRE home directory: i i [ Browse. .. ]
Defaulk ¥M Arguments: | |
IRE system libraries:

Add External JARs. ..

Restore Default

® o

Assign a name to the new JRE.
Enter the JRE home directory (when necessary, click Browse... to locate the file).
Add VM arguments when required.

Click OK to return to the New Server Runtime dialog box. Select the newly created JRE. Click OK.

Click Finish. The New Dynamic Web Project dialog box is displayed.

Y ou have completed the configuration of the flexible project, the server (Tomcat) and the JDK.
Change the Configurations to Custom and click Modify.

Select ApplinX Framework. Ensure that Dynamic Web Module and Java check boxes are sel ected.
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& New Dynamic Web Project A E|[‘5__(|

Project Facets 3
Select the facets that should be enabled For this project, \\)
Configurations: EDeFauIt Configuration For 12EE Funtime Library (23 | Save Delete
Project Facet YWersion
; Dn Applin Framework, .0
-] sz Web Services
1555 Dvnamic Web Module 2.5 -
F1L0 dava 5.0 -
] 4 JavaPersistence 1.0
[ =l JavaServer Faces 1.2 *
[1 = webDaclet {#Doclet) 1.23 -
<« Show Runtimes
l'f_ﬁl [ < Back ” Mext = l [ Finish ] [ Cancel

16. Click Next.
17. Click Next.
18. Select ApplinX installation from which to create the Web project and select the application type.

& New Dynamic Web Project

ApplinX Web Project Plugin <ol @
Select the source From which to create the wehb project, .-' a
Applink installation: | Ci\Program Files\Software AG\webMethods ApplinX | [Browse... l

Application bype: ! Wew Application w |

l'f_ﬁl Mext = Finish ] [ Cancel
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19. Click Next. Select Template screen is displayed.
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& Web Application Manager

(i
Bratws: ID

Brouss Propossls

—CNOCHE- 1 FECEIVERS

CHOCSE- W [IN-USE 7
+
CHOoEE- wCTIVE B

TR
CHOKEE- o BEQUEST 8

[2000-01-01preagos, Intvan
BOUAE  (2001-04-01Krasnenkn, Vladimr
BOURE |1992-02-0iGrass, andy

¥ P I Tatal

Action | Status [ ohoot' BroquetStact Date Folicy Molder Hame |
SR PR, I S e e | R
~CHOCGEE- w FECEIVER1 BOUSE |2004-05-0lvon Grusningen, Boherds.in
“CHOGSE «-Rmnﬁ'ﬁ BOUSE  [2004-02-D3Kantor, Edgar 1£76.09
CHOCSE- & UCTIVE [ BOUSE  Z003-1i-OZvan Bosch, Lea £5.91
—CHOGSE- e [IN-DSE J BO_'J::I-E_?E-DDl-DE-DlCh-pj-ll,CI_l 162 =3 91
oS- e BECETVERS HomE 2 ;

n7.53
les1. 8t
293,53

—cHotsE-  BECEIVERD

—CHOoSE- v RETIVE 14

-
-CHOOSE- » REQUEST (13

CNoomE- w FEQUEST (1%

FOUTE  [1005-04-010 ]
jE'T\’JEI !:DEIE—Oi—DEOrEi?(:w: ki, kdom

up bown

Serren i Tirwwsr Progesals )

T
A.o03

Select Template
Select the template bo use in your application.
Template: Preview!
Softwareds
Elue
Business
Red
Silver
Travel
-4
i
[
W
=L
™
w
-4
wd
- =
'—
=
[
3
Mage with
Gsoftusare=
@

< Back ]l_ Mext > |

Cancel

Select the template to use in your application.

20. Click Finish.

Y ou have completed the creation of a standard J2EE Web module.
21. Ensurethat in the Project menu, Build Automatically is selected.
To run the project, right-click on the project’ sfolder in the Project Explorer and select Run As> Run on Server ....
Thefirst time you run a project you are required to select a default server:

Select the server you configured.

Select the Set server as project default (do not prompt) checkbox.

The next time you run the application this dialog box will be displayed, with the default server selected.
Click Finish to continue. A browser window will be opened.

Note: The browser type can be configured under: general > Web Browser. It is recommended to configure it to: Default

system Web browser
Enabling using the Javadoc Functionality

When using the Javadoc you will have:

1 Online usage of the Eclipse Javadoc for ApplinX API
1 Suggested argument names for the ApplinX AP, instead of arg0,argl, etc.

» To use Javadoc capabilities when developing your project
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1. Right-click on the project node and select Build Path>Configure Build Path.... The Properties dialog box is displayed.
In the Librariestab, gxframework.jar node, click on the Javadoc location and then click on the Edit... button to determine

. the location of the Javadoc.
Enter http://localhost:2380/applinx-help in the Javadoc location path and click OK.

4. Click OK to close the Properties dialog box.

2

Creating an ApplinX Web Application using JDK and Tomcat (no | DE)

Note:

Thisis not available when working with a SOA license.

P To create a new JSP application without any | DE and with JDK:

Refer to the ApplinX JSP Framework Prerequisites.

file://C:\Documents and Settings\aacuna\Desktop\apx81\getstarted\A pplinX WebA pp.htm

1. During theinstallation process, choose the option ApplinX JSP Framework.
2.

In the ApplinX Explorer node, right-click on the relevant application and select Web Application Manager ....The Web

Application Manager Wizard is displayed.

& Web Application Manager

Web Application Manager

Select the task to perform,

The Weh application management wizard allows you to perform common \Web application tasks
such as upgrading an existing ApplinX Web application or creating a new Applini Web application,

Select the task to parfarm

{*)iCreate a new Web application (for IIS or Tomcat):

() Upgrade an existing Web application

Application screen is displayed.

3. Ensurethat Create a new Web application (for 11Sor for Tomcat) is selected. Click Next. The Create a New Web
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& Web Application Manager |:|@

Create a New Web Application
Select the language, application type and suitable name For the Web application,

Language

(#1350
Oicezao

OwB 2.0

Application type: ;New application

(7 [ < Back “ Mext > | Einish

4. Ensurethat JSPis selected. Select the application type: New application to create abasic ApplinX Web application with a
Web look and feel or Emulation template to create an ApplinX Web application with a host look and feel.

5. Click Next. Select Template screen is displayed.
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& Web Application Manager

=]

Select Template
Select the template bo use in your application.
Template: Preview!
Softwareds
Elue
Business
Red
Silver
Travel
Brouss Propossls
o Bratus: IDi
W Praposal Total
= Action | Etatus -‘;: i’:mn't'stut Date Folicy Holder Hame b
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={ ~CHOOEE~ W REQUEET F BOUSE [2004-02-02EKamtor, Edgar A7€.09
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had HOnSE- - FECEIVEES BoTEE  R001-03-01Gemax, Nandy 2a.a0
ce ~CHDSEE- % BECEIVERS BSE il-E.';ll:l-ID-UlFblllinU.lie-lt.r— g13.20
— ~ T - - e + - -
1 -CHOOSE- % UN-USE |7 BOUSE }:WU-UE-DIDL’&Q’D!,E!!—WI‘. A7.22
S ~CHOCSE- WIMTIVE @ BOUAE  (2001-04-D1Rrasnenka, Fladimic (161, 61
- CHOUSE- w BEQUEST B BSUHE  (1992-02-0iGrass, Mandy  294.53
—CHOCsE- % RECEIVEDID BOUSE  2004-02-012quict le, Cannop :éa.iﬁ
: —cHooeE- MPETIVE [k BOUSE  [1985-10-01Fingans, Felix 27,88
-CHOCSE- w REQUEST (13 BOUIE  2005-04-01M10 lec, Jobn 1an, 03
g ~CHOOSE- -\-lF‘[CII'I'EB'I' 13 BOUSE  2005-05-050r Likowslka, ko TJ.D':I
Help uic  Add up Cown
{Sereen. Il Tirwwsr Progesals
@ < Back ]l_ Mext = J Finish Cancel

Select atemplate from the list on the left.

6. Click Next. The New JSP Web Application screen is displayed.
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& Web Application Manager |;|@E|

Create a New JSP Web Application

Select the Tomcat installation Folder, The project will be created in this Folder,

‘Web application name:

Tomeat installation Folder:

._C:'I,devhome'l,t-:mcat—S.S |

JOK Folder:
| CHProgram Fes!Saftuars AGIJDKiv1 5.0

|:| Use Software AG common Tamcak

Enter a name for the Web application. By default thisis the name of the ApplinX application that you selected. Browse and
select the folder where Tomcat is installed. Select the location of the JDK installation.

When you wish to use Software AG's common Tomcat, select the suitable check box.
7. Click Next. The Wizard Summary screen is displayed.
8. Select whether to launch the browser when the process is compl eted.

9. Select whether to restart Tomcat. Thisis only relevant when Tomcat is activated from a batch file. The Framework Manager
does not support restarting Tomcat when Tomcat runs as a Windows Service (in this case, you need to manually restart
Tomcat).

10. Click Finish. A message will be displayed indicating whether the process succeeded or failed.

Note:
Any change in the Javafile requires recompilation of your new application. Changes in JSP files do not require recompilation.
Furthermore, Tomcat requires reloading: http:local host:8080/manager/rel oad?path=/<Y OUR_APP_NAME>.

4
Creating an ApplinX Web Application using Visual Studio 2005

# Tocreateanew ASP .NET application with Visual Studio .NET

If you do not have Visual Studio 2005, it is possible to download and use Microsoft Visual Web Devel oper 2005 Express Edition
from http://www.microsoft.com/express/2005/ (requires installing J#2.0 http://www.microsoft.com/downl oads/detail s.aspx?
familyid=f72c74b3-ed0e-4af 8-ae63- 2f 0e42501bel & amp; displ aylang=en& amp; displ aylang=en). When using this Edition, the add-
inswill not work.
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Install Microsoft Visua Studio.NET 2005 on your computer.

Open VS.NET 2005.

In the File menu select New and then Web Site... to create anew Web site. The New Web Site dialog box is displayed.
Select the relevant ApplinX Web application type (Visual C# or Visual Basic).

Run index.aspx page.

© 00~ w DN P

In the Framework Configuration Editor, define the connection parameters as follows:
a. Click on the Framework Configuration link. The Configuration Editor will be displayed.

b. Inthe Session node enter the Application name. By default the application name is "InstantDemo". In the Session
nodeit is possible to edit and configure additional connection and project properties.

c. Click Save to save your changes.
d. Click Closeto return to the Web application.

4
Creating an ApplinX Web Application using Visual Studio 2008

# Tocreateanew ASP .NET application with Visual Studio .NET

If you do not have Visual Studio 2008, it is possible to download and use Microsoft Visual Web Devel oper 2008 Express Edition
from http://www.microsoft.com/express/2008/ (requires installing J#2.0 http://www.microsoft.com/downl oads/detail s.aspx?
familyid=f72c74b3-ed0e-4af 8-ae63- 2f 0e42501bel & amp; displ aylang=en& amp; displ aylang=en). When using this Edition, the add-
inswill not work.

Install Microsoft Visua Studio.NET 2008 on your computer.

Install J# 2.0 redistributable.

Open VS.NET 2008.

In the File menu select New and then Web Site... to create anew Web site. The New Web Site dialog box is displayed.
Select anew .NET Web site (Visual C# or Visual Basic).

Delete all thefilesin the web site.

Copy al filesof the relevant ApplinX .NET web application from the installation into the web site in Visual Studio 2008.
Run index.aspx page.

© © N o bk~ WD P

In the Framework Configuration Editor, define the connection parameters as follows:
a. Click on the Framework Configuration link. The Configuration Editor will be displayed.

b. Inthe Session node enter the Application name. By default the application name is "InstantDemo". In the Session
nodeit is possible to edit and configure additional connection and project properties.

c. Click Save to save your changes.
d. Click Closeto return to the Web application.

Note:
.NET Plugins are not supported in Visua Studio 2008.

4
Creating an ApplinX Web Application using .NET SDK 2.0 (no IDE)

Note:
Thisis not available when working with a SOA license.

P Tocreateanew ASP.NET application without Visual Studio.NET with .NET SDK.

When you have more than one .NET SDK installed, ensure that I1Sis configured to work with .NET 2.0. Refer to ApplinX .NET
prerequisites.

1. During ApplinX installation select the ApplinX ASP.NET Web Framework C#/VB .NET option.
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3.

& Web Application Manager

Web Application Manager

Select the task to perform,

The Weh application management wizard allows you to perform common \Web application tasks
such as upgrading an existing ApplinX Web application or creating a new Applini Web application,

Select the task to parfarm
{*)iCreate a new Web application (for IIS or Tomcat):

() Upgrade an existing Web application

Page 13 of 15

In the ApplinX Explorer node, right-click on the relevant application and select Web Application Manager ....The Web
Application Manager Wizard is displayed.

Ensure that Create a new Web application (for 11Sor for Tomcat) is selected. Click Next. The Create a New Web

Application screen is displayed.

& Web Application Manager |Z|@“§|

Create a New Web Application
Select the language, application type and suitable name For the Web application,

Language

O

(IWB 2.0

Application type: | New application |

@ [ <ok J|_mwet> | e

4. Ensurethat C#2.0 or VB 2.0 are selected. Select the application type: New application to create a basic ApplinX Web

application with aWeb look and feel or Emulation template to create an ApplinX Web application with a host look and feel.

5. Click Next. Select Template screen is displayed.
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& Web Application Manager

=]

Select Template
Select the template bo use in your application.
Template: Preview!
Softwareds
Elue
Business
Red
Silver
Travel
Brouss Propossls
o Bratus: IDi
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= Action | Etatus -‘;: i’:mn't'stut Date Folicy Holder Hame b
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Help uic  Add up Cown
{Sereen. Il Tirwwsr Progesals
@ < Back ]l_ Mext = J Finish Cancel

Select atemplate from the list on the left. Click Next.
6. The Create a New .NET Web Application screen is displayed.
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& Web Application Manager

Create a New .NET Web Application

Select the folder in which the project will be created.

‘Web application name:

Destination folder:

| |[ Browse... ]

7. Enter aname for the Web application. By default thisis the name of the ApplinX application that you selected. Browse and
select the destination folder.

8. Click Next. The Wizard Summary screen is displayed.
9. Select whether to launch the browser when the process is compl eted.
10. Click Finish. A message will be displayed indicating whether the process succeeded or failed.

4
Upgrading an ApplinX Web Application from Visual Studio 2003 to 2005

» To upgrade a project from Visual Studio 2003 to Visual Studio 2005
1. Convert the project as detailed in the following link: http://msdn.microsoft.com/en-ug/library/ms228097.aspx, Migrating a
Visual Studio .NET 2003 Web Project to a Web Application Project.
2. Closethe upgraded project.
3. In ApplinX upgrade your Web application using the ApplinX Web Application Manager.
4. Reopen the project in Visual Studio 2005.
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