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Introduction 

This paper shows different ways to deploy Explorer software within an enterprise 

for system administrators. By reading this paper, you can: 

• Get an overview of the options for deploying Explorer software 

• Review the advantages and disadvantages of each technique 

• Learn how to customize your Explorer installation 
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Deployment considerations 

IBM Explorer for z/OS (z/OS Explorer) and CICS Explorer run on Linux, Microsoft 

Windows, and macOS platforms. They are available as separately licensed 

components at no charge for use with IBM z/OS enterprise operating system, IBM 

CICS Transaction Server for z/OS, and other CICS products. For details about 

licensing and entitlement for use, check the Software License Agreements search 

web page.    

IBM z/OS Explorer helps manage connections to any number of z/OS mainframe 

systems, so you can create, edit, administer, and delete artifacts, including data 

sets, z/OS UNIX files, and z/OS jobs.  

To minimize the number of separate tools and products that are required to be 

installed on a user’s system, z/OS Explorer acts as an integration platform for 

installing tools to manage a range of z/OS subsystems, such as CICS, IBM DB2®, 

IBM WebSphere® MQ, IBM IMSTM, and other software.  

CICS Explorer is built on top of z/OS Explorer as a simple, easy to use management 

tool for one or more CICS systems. It provides functions to view and manage CICS 

Transaction Server regions and CICSplexes, as well as a platform for the integration 

of CICS tools. CICS Explorer also facilitates developing and deploying OSGi 

applications in a CICS Java virtual machine server.  

Using standard Eclipse technology means that the Explorer products benefit from 

strong integration with other Eclipse-based products from IBM and other vendors. 

But it also means that Explorer must remain within the parameters and standards of 

the Eclipse platform to assure interoperability.  

Appendix A, “Comparison of technologies”, provides a comparison table that 

summarizes the advantages and disadvantages of each deployment technique. 

Getting started 

Perhaps you have downloaded z/OS Explorer or CICS Explorer already. There are 

two main technologies that are involved while installing and updating: IBM 

Installation Manager and Eclipse p2.  

https://www.ibm.com/software/sla/sladb.nsf/search/
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Within either of these technologies, you can download the stand-alone product or a 

plug-in to extend another product that is already installed.  

Over time, the set of supported scenarios and the available downloads evolve, of 

course. For z/OS Explorer and CICS Explorer of current releases, the following 

installation mechanisms are available: 

For z/OS Explorer: 

• The z/OS Explorer launchpad. If you are starting from scratch, this provides 

both the IBM Installation Manager software and z/OS Explorer, with the 

option to install plug-ins and tools.  

• If you already have Installation Manager installed, you do not need to 

download anything. Add the repository URL listed on the z/OS Explorer 

download page by clicking File > Preferences within Installation Manager, 

and then clicking Install. 

For CICS Explorer:  

• The CICS Explorer p2 download. The .zip or .tar.gz file provides a copy 

of CICS Explorer that can be extended and updating by using the Eclipse p2 

technology.  

• To use Installation Manager, install z/OS Explorer by following the z/OS 

Explorer guidance. Find the repository URL available on the Mainframe DEV 

page by navigating to IBM Installation Manager > Extend an existing 

Installation Manager instance. Add the repository by clicking File > 

Preferences > Repositories > Add Repository within Installation Manager, 

and then click Install.  

• To add CICS Explorer to an existing copy of a supported version of Eclipse, 

add the update site URL available on the Mainframe DEV page by clicking 

Help > Install New Software within Eclipse, and then choose the features to 

install. 

Managing Explorer artifacts 

With a carefully thought-out deployment of Explorer, a system administrator can 

achieve a good balance of performance for the user and control over the software 

that is running within the enterprise. With planning, even some deeper aspects of 

https://developer.ibm.com/mainframe/products/downloads/eclipse-tools/
https://developer.ibm.com/mainframe/products/downloads/eclipse-tools/
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the user experience, such as the connections available by default, can be controlled 

in most situations. 

There are many ways to deploy Explorer software, each with advantages and 

disadvantages: 

• Using the standard p2 mechanism that is built into the Install New Software 

menu within the Eclipse Help  

•  Using IBM Installation Manager  

•  Hosting on a shared network  

In the same way that an office productivity suite or a web browser is installed, the 

Explorer software must be run from the user's workstation (see Figure 1, where 

CMCI stands for CICS management client interface). Therefore, the installed files 

are stored on the user's workstation, updates must be applied on the user's 

workstation, and backups must be taken into account. There are techniques that 

you can use to retain control of the product code elsewhere, for instance using a 

network share, but the product code always runs on the user's workstation. 

Figure 1: CICS Explorer system architecture 

By design, Eclipse-based applications are easily customizable so that you can offer 

your users an experience that is tailored for their job roles. To make this level of 

customization possible, some artifacts are stored on disk in addition to the Explorer 

product code. Understanding what is stored and how to control where it is stored is 

essential to managing rollouts, particularly when you are sharing an Explorer 

product installation among users. 

Note: Without due consideration of the appropriate deployment technique for 

your enterprise's situation, system administrators might get complaints from 

users and encounter difficulty in managing the Explorer products adequately. 
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Installation area directory 

The installation area contains the executable code, plug-ins, and features. If the 

Explorer software is extended with other tools, their plug-ins and features are also 

installed in the installation area.  

When you install the software, you choose the installation directory.  

Configuration area directory 

The configuration area contains some internal information about CICS Explorer: 

Which plug-ins and features are installed, some basic preferences (including which 

workspace was last used), and temporary data that is accessed by Explorer while it 

is in use.  

By default, the configuration directory is stored within the installation directory. 

Workspace directory 

The workspace (or instance area) contains any files that are stored by the users, 

such as bundled projects and text files that they created in the Resource 

perspective. Some tools store files in the workspace (CICS Explorer plug-in’s 

Configuration Manager job control language [JCL] templates, for example). Several 

preferences, such as the user's view customizations and available connections, are 

also stored in the workspace.  

Users can have more than one workspace to use with the same Explorer product. 

For instance, the user might administer systems for two different clients and need 

to keep the connections and sets of bundles separate. Or the user might be 

developing applications for two different releases of CICS simultaneously.  

Because the workspace directory contains most of the user's preferences and files, 

it is the most critical one to back up before upgrades and for disaster recovery. 

Remote system connections 

z/OS Explorer provides a connections framework to tools that extend it. The 

connections framework keeps track of connection details and related credentials. 

For instance, you might have an FTP connection that is defined within z/OS 
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Explorer. If you have CICS Explorer installed also, you might have several 

connections to your IBM CICSPlex® System Manager (CICSPlex SM) web user 

interface (WUI) servers. These might all require the same credentials for 

connection, or they might require separate credentials.  

Connection information is stored in the user's workspace. As a system 

administrator, you might need to frequently make sure that a set of CICS 

programmers all have the same set of, for example, 10 connections to production 

regions. Emailing all of your users to ask them to change the port number of a 

particular region is an inefficient and unreliable way of working. To help with this 

scenario, z/OS Explorer provides an export mechanism to record your set of 

connections as an XML file. Your users can then use this XML file to populate their 

set of connections. 

When a user chooses to use an XML file of exported connections, they can choose 

to import the file or to load it. Importing the file creates local connections that the 

user can edit. Loading the file creates connections that the user cannot edit and 

that will synchronize with the original source.  

Explorer can use connections files stored both on disk, for example on a shared 

network drive, or hosted behind HTTP, for example, a web server or a CICS URIMAP 

resource definition.  

Appendix B, “Using plugin_customization.ini to customize users’ workspaces”, 

explains how you might use the pluginCustomization feature to provide users with a 

set of connection preferences that are loaded from an HTTP server when they first 

use Explorer. 

Customizing and sharing view configurations 

z/OS Explorer provides users with the flexibility to customize how data is presented 

in a view. Users can action against data in the view directly, and CICS Explorer 

Note: Using the Load Connections function, the system administrator gains 

central control of the set of connections available to users and can push updates 

to users' installations. 
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remembers how data is displayed when the view is closed. For users to create 

views of their own, CICS Explorer provides a View Configuration dialog to customize 

the view layout in one place and save different view configurations for later use. 

View configurations are stored in the user’s work space and can be shared as an 

xml file. As a system administrator, you can make sure that all your users use the 

same enterprise-tailored views by sharing custom view configuration files with your 

users. 

For more information on how to create, import, or export a customized view, see 

Viewing CICS resources. 

Using z/OS Explorer as an integration platform 

The power of z/OS Explorer lies in your ability to extend it with tools to support your 

organization's work. Perhaps your team manages a CICS deployment, uses IBM 

CICS Deployment Assistant to help manage their CICS topology, and requires IBM 

Debug Tool for z/OS to debug CICS applications. Each of these tools provides a 

plug-in that is compatible with z/OS Explorer.  

Depending on the deployment mechanism that you choose, you might need to 

preinstall the tools for the user, provide a silent installation script that automatically 

provisions the correct versions on the user's system, or make it simple for users to 

choose the set of tools most appropriate to their situations. IBM provides a 

repository and an update site, shown in Figure 2, that contains compatible versions 

of various tools, all accessible from one URL. The latest URL for our Aqua 3.2 

release is:  

https://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.2/ 

https://www.ibm.com/support/knowledgecenter/SSSQ3W_5.5.0/com.ibm.cics.core.help/topics/tasks/task_configure_view.html
https://www.ibm.com/support/knowledgecenter/SSSQ3W_5.5.0/com.ibm.cics.core.help/topics/gettingstarted/tutorial_views_overview.html
https://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.2/
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Figure 2: IBM update site that contains compatible tools 

The Mainframe DEV website also provides a simple roadmap to download and 

install any Eclipse tool you need, depending on the installation method and the 

environment context you specify. Update sites for extending an existing Eclipse 

instance using the Eclipse p2 installation client can all be found on the Mainframe 

DEV website. 

Choosing the correct technology is nearly as important as sticking with it. Mixing 

installations of different types, such as Installation Manager and p2, is not 

advisable and is likely to lead to problems for your users. 

Keeping your users up-to-date 

The IBM repository of compatible products is a single URL you can use in the 

Explorer products to provide access to a set of tools that are verified to work 

https://developer.ibm.com/mainframe/products/downloads/eclipse-tools/
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together in the Explorer environment. When a new fix or modification level update is 

released for a tool, IBM refreshes the repository. By using the repository or update 

site URLs, your users can keep up-to-date with the latest compatible versions of the 

installed tools.  

If you need considerable control over the software versions that are available to 

your users, but you choose a technology where the user can install more tools, you 

can host the repositories that contain the IBM product code on your intranet. This 

enables you to test new versions of the tools and make them available to your team 

in a controlled manner.  

The update happens in different ways, depending on the deployment mechanism 

that you choose. For some mechanisms, Explorer checks for updates when it starts 

and forces the user to wait while available updates install or a new version of 

Explorer downloads. For others, your desktop client team can push a trigger to 

initiate an automatic software update. 

Using IBM Installation Manager 

IBM Installation Manager is an installation technology that is provided by IBM to 

manage the installation and upgrade of IBM products. Installation Manager also 

provides silent installation and upgrades if preferred and can be easily integrated 

into existing desktop management solutions that roll out software in your 

enterprise.  

For compatible Eclipse applications, including the IBM Explorer products and many 

of the IBM Rational product suites, Installation Manager enables shell sharing 

(allowing access to all compatible products from one host product) and manages 

common components to reduce disk space use.  

Installation Manager needs to keep track of the software that is present within an 

Explorer installation to manage dependencies and upgrades correctly. If you install 

Explorer by using IBM Installation Manager, you must make sure that, wherever 

possible thereafter, you use Installation Manager to extend and upgrade the 

installation. 
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Benefits 

Using IBM Information Manager offers several benefits:  

• The silent installation and upgrade capability make Installation Manager 

easy to integrate into desktop management solutions.  

• Installation Manager includes good shell-sharing capabilities.  

• The architecture of IBM Installation Manager means that in many cases it is 

possible to upgrade all elements of the Explorer installation without 

requiring a reinstall. 

Drawbacks 

There are a couple of drawbacks to using Installation Manager:  

• It requires a relatively heavyweight installation process.  

• It is difficult to introduce customizations. 

Installing software 

The Installation Manager is installed onto your workstation. You add repositories 

into the Installation Manager, which can be local directories, compressed files 

hosted within your local computer or on your intranet, or a URL provided by IBM, 

and then install products from these repositories. Installation Manager prompts for 

additional information as required and installs the product. Products are assigned 

into Package Groups. Items within the same package group share some installation 

files and, therefore, must be compatible. The Installation Manager takes care of 

ensuring compatibility. In most cases, product upgrades are seamless. 
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Silent or unattended installation 

IBM Installation Manager provides support for silent installations, which require no 

input from the user. The Installation Manager can be silently installed at the same 

time as the Explorer software.  

The process to create a silent installation (Figure 3) involves creating and editing a 

response file. The response file can add repositories; install, update, or remove 

packages; set up licenses; and trigger the user's workstation to reboot after 

installation. After creating the response file, distribute it to your users' work 

stations by using your standard desktop management mechanism, and then run it. 

Figure 3: Using IBM Installation Manager for a silent installation procedure 

For more information, see the Knowledge Center for IBM Installation Manager. 

Installing additional plug-ins and tools 

Installation Manager maintains its own registry that tracks which software is 

installed into which Package Group and which versions of which files are on the 

disk. By tracking the Explorer software this way, the Installation Manager can 

Note: By using silent installation, you can push the Explorer software to a user's 

workstation by using your standard desktop management mechanism and forcing 

the application of updates. The users do not need to know how to use Installation 

Manager, so they are free to focus on their jobs. 

https://www.ibm.com/support/knowledgecenter/SSDV2W/im_family_welcome.html
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manage product dependencies accurately and roll the installation back to a 

previous state, if necessary. 

If you are accustomed to using Explorer without Installation Manager, you might be 

familiar with installing additional software either by using the drop-ins folder or by 

selecting Help and then clicking Install New Software (this is the Eclipse Update 

Manager facility, which manages extensions and updates by using the p2 

provisioning engine that is built into Eclipse). If you use Installation Manager to 

install the Explorer software, you should use Installation Manager to install 

additional software and to update installed software. This is the best way to avoid 

problems with Installation Manager being unable to update your Explorer 

installation.  

In situations where you must install a plug-in that is not available in the Installation 

Manager format, it is possible to use the Eclipse Update Manager. However, choose 

that option only as a last resort. If you install the plug-in by using Eclipse alters files 

that are managed by Installation Manager, you might have problems keeping the 

software up-to-date in the future. 

Keeping up-to-data 

Installation Manager installations are updated by the Installation Manager tool. You 

can trigger this by using the Update option in the Installation Manager tool or by a 

silent installation script.  

The option to use silent installation scripts means that you can, for example, create 

a scheduled task to regularly check for, and install, available updates. 

Rehosting Installation Manager repositories within your network 

IBM provides a repository of compatible versions of a number of products on IBM 

servers. If you do not want your users to access the IBM repository for product 

Note: It is important not to mix Installation Manager and Eclipse Update Manager. 

If you installed a product by using Installation Manager, it must be updated by 

using Installation Manager. 
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installations or updates, you can use the IBM Packaging Utility to download a 

repository containing the required features, sourced from the Mainframe DEV site.  

The downloaded features are stored in a repository on your disk. You can rehost the 

repository on your network or pass it to your users as a compressed file, perhaps as 

part of your desktop management mechanism.  

To use the IBM Packaging Utility, download it and install it. When you start the 

utility, you can choose to copy packages from a remote repository into one on your 

local disk, or to delete packages from a repository on disk. If you are rehosting the 

repositories internally, you might prefer to provide your users with Installation 

Manager by downloading it to avoid sharing the large launchpad .zip file around 

your internal network. You can download the utility from the Installation Manager 

and Packaging Utility web page. For more information, see IBM Packaging Utility in 

the IBM Knowledge Center.  

Using the Eclipse Update Manager 

Eclipse-based products contain a feature to manage software installation and 

upgrades called Eclipse Update Manager. The Update Manager uses the Eclipse p2 

provisioning tool to manage installation and updates to Eclipse features from 

update sites. By clicking Help > Install New Software and using the menu that is 

built into IBM Explorer, you can add external websites, host update sites on your 

intranet, use folders, or use local .zip files that contain software and select 

components to install into Explorer. 

Benefits 

Using the Eclipse Update Manager offers these benefits:  

• It manages dependencies and version requirements. This prevents 

incompatible software from being installed.  

• You can use local update sites hosted on your network or distribute update 

sites to your users as archive files. This gives the system administrator some 

control over when updates happen and which code is in use. 

https://developer.ibm.com/mainframe/products/downloads/eclipse-tools
https://www-01.ibm.com/support/docview.wss?uid=swg27025142
https://www-01.ibm.com/support/docview.wss?uid=swg27025142
https://www.ibm.com/support/knowledgecenter/SSSH27_9.0.1/com.ibm.rational.clearcase.cc_ms_install.doc/topics/c_packaging_intro_rsar.htm
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Drawbacks 

Using Eclipse Update Manager involves a few drawbacks:  

• IBM Explorer checks for updates only at start-up (and updates can be 

cancelled) or when the user triggers a check.  

• Silent updates cannot be set up easily.  

• Eclipse Update Manager cannot upgrade some elements of the installation. 

For example, the Java Runtime Environment (JRE) that runs Explorer and 

some parts of the Eclipse system cannot be upgraded. Because of this, 

upgrades to newer versions of the Explorer software sometimes require a full 

reinstallation of Explorer when you use the Eclipse Update Manager. 

Installing Explorer software 

For an Eclipse Update Manager installation, CICS Explorer is supplied in a .zip file 

on Microsoft Windows and macOS platforms or a tar.gz file on Linux systems. To 

install CICS Explorer, decompress the file to a suitable location on the workstation. 

Installing additional plug-ins and tools 

IBM CICS Explorer is configured to use the IBM Explorer for z/OS update site. By 

clicking Help > Install New Software and choosing to work with this update site, 

you can quickly install various compatible IBM tools and products. Alternatively, 

you can add an update site that is provided to you by a vendor.  

If you prefer not to use the IBM Explorer for z/OS update site, you can manage your 

available repositories by clicking Windows > Preferences. 

Keeping up-to-date 

By clicking Help > Check for Updates, you can trigger CICS Explorer to find and 

install available updates. CICS Explorer looks for updates in all enabled update 

sites.  

By clicking Window > Preferences, you can set a schedule to check regularly for 

updates, or to check each time CICS Explorer is started. 
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Appendix B, “Using plugin_customization.ini to customize users’ workspaces”, 

explains how you can use the pluginCustomization technique to set preferences for 

users the first time that they use Explorer.  

For information about a set of preferences that influence the auto-update behavior, 

see the Configuring the UI Policy section of the Eclipse documentation. 

Rehosting p2 update sites on your network 

If you do not want users to access the IBM update site for plug-in installations or 

updates, you can download a copy of the update site by using the Eclipse p2 

mirroring tools that are built into IBM CICS Explorer.  

To mirror a repository, follow these steps: 

1. Identify the URL of the repository, which can be found in either of the 

following ways:  

• Go to the Mainframe DEV site, select your product, and choose Eclipse 

p2 as the installation client and Extending an existing Eclipse instance 

as the starting point. You will find the URL on the Download and install 

page, similar to the screen shot below:  

Figure 4: Download and install page on Mainframe DEV 

http://help.eclipse.org/photon/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Fguide%2Fp2_uipolicy.htm
https://developer.ibm.com/mainframe/products/downloads/eclipse-tools/
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• In CICS Explorer, click Help > Install New Software. The URL is 

available from the drop-down list in the Install dialog. 

Figure 5: Install dialog of CICS Explorer 

2. Specify where you want to store the repository, for example: 

c:\temp\updatesite  

3. Run CICS Explorer with the following additional command-line arguments: 

zosexplorer.exe -consoleLog -application 

org.eclipse.equinox.p2.artifact.repository.mirrorApplicat

ion -source http://url/to/repository -destination 

file:c:/temp/updatesite  

This starts CICS Explorer but with the p2 mirror application rather than the 

standard CICS Explorer GUI, which then mirrors the -source argument into 

the -destination argument.  

4. Run the command again to mirror the metadata also. There are two parts to a 

p2 repository: artifacts and metadata. 

Replace  
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org.eclipse.equinox.p2.artifact.repository.mirrorApplicat

ion  

with  

org.eclipse.equinox.p2.metadata.repository.mirrorApplicat

ion  

For more information, see Mirroring repositories with p2 in the Eclipse 

documentation. 

Using a network drive for installation 

The simplest way to share an IBM CICS Explorer installation between multiple 

users is using a network drive. By following guidelines that are explained later, the 

system administrator prepares and configures the required version of CICS Explorer 

with any required plug-ins installed and then puts it onto a network drive.  

Users access CICS Explorer directly from the network drive. CICS Explorer is set up 

so that the configuration area and workspaces are stored on users' local 

workstations. The users can then develop OSGi bundles or access their own 

connections. 

Benefits 

Using a network drive offers these benefits:  

• A shared network drive is simple to set up and administer.  

• The system administrator has control over the version of the software. 

Drawback 

CICS Explorer can be slow to start when hosted on a shared network drive. The 

start-up speed depends on the speed of the connection. 

Setting up a shared version of CICS Explorer 

When you deploy CICS Explorer by using a shared network drive for multiple users, 

the main consideration is to ensure that Eclipse does not attempt to store user data 

http://help.eclipse.org/photon/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Fguide%2Fp2_mirror.html
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within the shared part of the installation. The simplest way to do this is to make the 

installation read-only.  

The Eclipse website provides documentation that describes the steps that are 

required to set up a multiuser installation. 

Installing other plug-ins and tools 

At first glance, distributing plug-ins as part of a CICS Explorer shared network drive 

installation looks simple. You expect just to install the plug-ins before you put the 

package on the network drive. However, by starting CICS Explorer to install the 

required plug-ins, you will inadvertently seed some of the configuration, including 

the recently used workspace list.  

Instead, use the p2 director tool that is provided with Eclipse and CICS Explorer. 

This process is described in Appendix C, “Using the p2 director to install plug-ins 

and tools”. 

Keeping up-to-date 

To update the version of CICS Explorer that is available, the system administrator 

updates the version that is stored on the network drive. It is safest to re-create a 

fresh installation with all the required components at the correct level to avoid 

starting the CICS Explorer instance and initializing the configuration with 

unintended preferences, such as the recently used workspace list. 

Using Installation Manager installs from a network drive 

To install z/OS Explorer and additional tools and use them from a network drive, 

you must choose one workstation to be the main and then perform the installation 

from this workstation. The Installation Manager executable files and the 

Installation Manager registry are stored on that workstation.  

Note: For further customizations, such as adding a connection provider, you can 

use the plugin_customization.ini technique that is described in Appendix 

B, “Using plugin_customization.ini to customize users’ workspaces”, to set default 

preferences for the workstations. 

http://help.eclipse.org/photon/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/misc/multi%255Fuser%255Finstalls.html
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During the installation, when you are prompted for the location for IBM z/OS 

Explorer and the Installation Manager shared resources, choose a location within 

your shared drive. From there, continue to follow the standard Eclipse process for a 

normal shared installation.  

So that the supporting files can be found, your client workstations that run z/OS 

Explorer must map the same network drive to the same drive letter as on the main 

when z/OS Explorer was originally installed. To apply updates, you need to make 

the z/OS Explorer directory writeable and then use the main workstation to run 

Installation Manager and update the installation before you make it read-only 

again.  
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A. Comparison of technologies 

 IBM Installation 

Manager 

Eclipse p2 Network drive 

Ease of client 

setup 

Medium Easy Easy 

Ease of server 

setup 

Medium N/A Medium 

Client installation 

speed 

Slow Fast N/A 

Client load speed Fast Fast Slow 

Ease of 

customization for 

administrators 

Hard Medium Easy 

Ease of 

customization for 

users 

Easy Easy Medium 

Level of control 

over version in use 

Medium Low High 

Ease of rehosting 

repositories 

internally 

Easy Medium N/A 

Compatibility with 

vendor Eclipse 

plug-ins 

Medium Good Good 

Compatibility with 

IBM products 

Good Good Good 
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B. Using plugin_customization.ini to 

customize users’ workspaces  

Many of the changes that you make to your IBM Explorer environment are persisted 

between sessions by using the Eclipse Preferences framework. Eclipse provides a 

feature called pluginCustomization that you can use to suggest default values for 

these preferences.  

You can use this technique to provide defaults for users with a fresh installation. For 

example, you can specify a remote connection provider to be added when the user 

first starts up.  

The following steps are involved in rolling out default preferences in this way:  

1. Modify your local CICS Explorer and Export preferences. Establish which 

preferences to be applied to newly rolled out CICS Explorer instances. 

2. Specify the preferences that you want to apply and create a 

plugin_customization.ini file to contain them.  

3. Roll out the plugin_customization.ini file to your users in their 

CICS_Explorer directories, where CICS_Explorer is the installation 

directory of their CICS Explorer instance. 

This example shows you how to add a remote connection provider. 

To begin, start CICS Explorer with a new workspace and load a remote connection 

provider from a URL. 

Export the preferences by clicking File > Export > Preferences. Open the exported 

file, which contains general Eclipse preferences and Explorer-specific preferences. 

The pair of lines that relate to the loaded connection provider looks like the 

following example. 

/instance/com.ibm.cics.core.connections/connections/CONNE

CTION_SOURCES/13784619493 45-

0/LOCATION=http\://myserver/connections.pref 
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The preference starts with /instance/, which indicates the scope that the 

preference was exported from. The instance scope means that they were stored in 

the instance area or workspace. You need to remove the scope as the following 

example shows before you add it to the plugin_customization.ini file. 

com.ibm.cics.core.connections/connections/CONNECTION_SOUR

CES/pluginCust-2013090611 

31/LOCATION=http\://myserver/connections.pref 

Note that you also need to replace the randomly generated number in the 

connection provider preference with a string to ensure that there can be no clashes.  

After appending this to the plugin_customization.ini file provided in the 

CICS_Explorer directory, starting Explorer with a new workspace sets this 

preference by default. If a workspace in use already has a preference with the same 

key already set, that preference is not overwritten. 

Preference names and details are not considered part of the API, so they might 

change between releases of CICS Explorer or Eclipse. 
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C. Using the p2 director to install 

plug-ins and tools 

If you are not using IBM Installation Manager to manage your IBM Explorer 

installations, your users normally start the Explorer client and use the Help menu 

options to install new software. If you are configuring an Explorer instance to share 

with multiple users, avoid starting the Explorer client before distributing Explorer to 

your users. If you start the client, some preferences are set in the installation area, 

including the recent workspaces. In most cases, you will not want to distribute a 

client that has these initial preferences set, because the recent workspace list is 

specific to the computer that you are working on, not your users’ workstations.  

Instead, use the Eclipse p2 director to install any additional plug-ins and tools that 

your users require.  

First, establish the feature IDs that need to be installed. Use the GUI in a separate 

copy of Explorer. Click Help > Install New Software and select the repository that 

you want to install from. Choose the software features that you want to install, and 
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click Next. Make a note of the top-level feature IDs of the features that you choose. 

The choice is outlined in red in the example in Figure 6. 

Figure 6: Find the ID of the feature you want to install 

Now, run the separate copy of CICS Explorer by using a command similar to the one 

that is shown in the following example. Enter the command on one continuous line. 

(New lines appear in the following example merely for clarity.) 

/path/to/CICS_Explorer_host/cicsexplorer 

-application org.eclipse.equinox.p2.director 

-repository 

http://public.dhe.ibm.com/software/htp/zos/2/1/0/ -

installIU com.ibm.cics.pa.feature.feature.group 

-destination /path/to/CICS_Explorer_for_distribution/ 

This command starts the p2 director application (rather than the CICS Explorer 

application). Specify the following details: 

• The repository that contains the updated site code (the one that you chose in 

the GUI)  

• The name of the features to install (separate by commas if more than one)  
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• The copy of CICS Explorer where you want to install the plug-in 

For more information, see Installing software using the p2 director application. 

 

  

http://help.eclipse.org/photon/index.jsp?topic=%2Forg.eclipse.platform.doc.isv%2Fguide%2Fp2_director.html
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Find more information 

Use the following resources to learn more about CICS Explorer and its latest 

enhancements. 

CICS Explorer 5.5 enhancements 

Knowledge Center for CICS Explorer 

Knowledge Center for IBM Explorer for z/OS 

Eclipse documentation 

Blogs by CICS Explorer experts 

CICS Explorer downloads 

Marketplace: CICS Explorer product page 

If you have any questions, please feel free to let us know by contacting IBM 

Support. 

  

https://developer.ibm.com/cics/hot-topic-cics-explorer-enhancements/
https://www.ibm.com/support/knowledgecenter/SSSQ3W
https://www.ibm.com/support/knowledgecenter/SSBDYH/welcome.html
http://help.eclipse.org/photon/index.jsp?nav=%2F0
https://developer.ibm.com/cics/category/cics-explorer/
https://developer.ibm.com/mainframe/products/downloads/eclipse-tools/
https://www.ibm.com/us-en/marketplace/cics-explorer
https://www.ibm.com/support/home/
https://www.ibm.com/support/home/
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Notices 

Notices applicable to this publication are available here: https://developer.ibm.com/cics/legal-notices/ 

 

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 

PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER 

EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 

WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, OR FITNESS 

FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of 

express or implied warranties in certain transactions, therefore this statement may 

not apply to you. 

 

Trademarks 

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 

International Business Machines Corp., registered in many jurisdictions worldwide. 

Other product and service names might be trademarks of IBM or other companies. 

A current list of IBM trademarks is available on the web at "Copyright and 

trademark information" at www.ibm.com/legal/copytrade.shtml. 

  

https://developer.ibm.com/cics/legal-notices/
http://www.ibm.com/legal/us/en/copytrade.shtml
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